Composition Mode (Center Screen Typing)


When I attempt to use composition screen since the upgrade to 3 the screen no longer centers to the middle when I start typing. I always types at the bottom of the screen. I have attempt to go to Preferences >> Editing >> Options >> and played around with" Typewriter scroll line dropdown" and “always jump to scroll line” but nothing changes. I don’t see anything in Appearance >> Composition Mode >> Options to change this setting. I prefer to write in the center of the screen.



Check to see if View > Text Editing > Typewriter Scrolling is on or not.

That works fine in document mode but not composition (full screen) mode.

Ah, does on my Mac. Corrupt installation?

Ok all is well. I realized that I needed to follow the same steps above while in composition mode. When in that mode you don’t see the file edit view… options unless you mouse up. Silly me, Thanks!!!

The Typewriter Scrolling settings for the editor and Composition Mode are independent of each other - just because you have it set in the editor doesn’t mean it will be on when you move to Composition Mode or vice versa. It’s also independent for each half of a split editor. Wherever you are, the shortcut is cmd-ctl-t.

So, you turn it on as a default using preferences, then toggle it on or off for each editor/composition as required.

BTW, there are a couple of enhancements to typewriter scrolling in V3, so it’s worth reading the manual section, which begins at Section 15.3.4.


For me, the problem is that, in both Editor and Composition modes, the scrolling occurs only eight lines down from the top. I have my preferences set to center of the screen, and I have typewriter scrolling turned on for both modes.

And it’s inconsistent. It seems that this happens only with new index cards but not with existing cards. That is, I converted my current projects to 3.0 last week. When I edit cards that existed before the upgrade, the scrolling works just fine. It’s only when I add new cards that the behavior is wrong.

In Preferences > Editing > Options, if “Typewriter scrolling always jumps to scroll line” is checked, the behaviour in 3.0 should be the same as in version 2, with the current line jumping to whatever location you’ve set as the scroll line in the dropdown above. Bear in mind though that if there is not enough text in the document, it will not jump but continue down new lines until you reach the scroll line.

If “Typewriter scrolling always jumps” is deselected, the scroll line will be wherever you click and begin typing (within a certain distance of the top of the editor, so it’s not right on the edge), so the editor is not always shifting. You can use Cmd-J to jump to the set scroll line in this case.

I’ve tried that already. It doesn’t solve the problem.

It doesn’t wait until I’ve typed down to the center of the page before the automatic scrolling begins. It starts on the eighth line. Once I’ve typed a bunch more on the page, if I go to another application and then come back, the scroll line is centered on the page as it’s supposed to be.

This is something I never had an issue with in the old version. It’s one of my many frustrations with the upgrade. It’s taking way too long just to reset all of my basic preferences that weren’t carried over, and then when I get the settings right, some of them still don’t work. Such is life.

If you ticked “Typewriter scrolling always jumps to scroll line” as Jennifer suggested, then the behaviour is identical to the behaviour in Scrivener 2 - the code is the same in that case. Perhaps you can provide instructions on how to reproduce the problem?

It’s exactly as I already said. I add a new index card. I open the card in the main editor or in composition mode. I begin typing. After only a few lines, the automatic scrolling begins.

In the old version, the automatic scrolling didn’t begin until I’d typed down to the center of the screen.

Have you changed the “Typewriter scroll line” setting in the “Editing” Preferences at all? I can reproduce nothing like this.

I’ve tried all of those settings. I’ve ticked and unticked and tried all kinds of different combinations. Nothing works. At this point, I have a highly unsatisfying work-around and assume that’s what I have to live with. This kind of thing kills Scrivener’s usefulness for me. It’s really disappointing.

I’m a developer in my real job, and I get that you can’t fix it if you can’t duplicate it. But from a practical standpoint, as a user, that’s unacceptable, considering I just paid for an upgrade that makes the software less useful to me.

If you can reproduce it consistently in a sample project, then zip it and post it here for L&L to review.


Did you try it with a project created in the old version that you updated to the new version? (It seems fine when I create a new project in the new version.) The issue has been consistent across all projects that I’ve updated from old to new. I mentioned this in my first message but realized I didn’t include it in my second. My apologies for the oversight.

Yes, I’ve tried that but I still cannot reproduce it and have no other reports of anything similar. Could you please list out the exact steps I need to reproduce it? i.e. Start with a project in 2.x with such-and-such settings, open in Scrivener 3, type in a new document (or typing in an existing document with lots of text?), whereabouts to type on the screen (at top of existing text, at top of empty text etc). Or maybe a quick screen cast showing the issue and all of your settings might cast some light on it.

Thanks and all the best,

I just gave that a try. I created a test project with default settings in Scrivener 2 from a blank project, containing two documents: one with several screens of text and another empty. I then closed this, updated it with v3 and tested both the full document and the empty one. My settings were to always jump to the scroll line and to use the middle of the screen.

With the document that had a lot of text, whenever I placed the cursor and started typing, it jumped to the middle of the screen. In the document that was empty, I increased the magnification to 150% and made the
“paper” width narrow so I could get to the described condition faster—and it took until I reached the middle of the screen before typewriter scrolling kicked in.

It might be settings related, so the earlier advice to post a simple test project that demonstrates the problem might be good. There are a lot of conditions that could be a factor (like zoom settings, etc.).


Did you try it with different zoom settings? I generally use a setting between 50 and 75% in both main editor and composition mode. When I zoomed out even to 100%, it seemed fine, let alone 150%, so it must be at least somewhat related. (Even if that doesn’t necessarily make sense. By zooming out to 150%, the opposite should happen, i.e. it shouldn’t start scrolling until farther past center.)

Regardless, I’ve been using the 50-75% zoom for years in the old version without this issue coming up.

FYI, for testing, you can just type a word or two and return until you’re down several lines. The behavior has been the same for me whether I do that or just type as usual, so I just use a lot of one-word lines to save time.

Okay that was the trick. :slight_smile: I wouldn’t have thought to decrease the zoom to 50%, sorry if I missed that condition earlier. I can easily reproduce in a new blank project with:

  1. Open Composition mode.
  2. Decrease zoom to 50%.
  3. Type in a few letters.
  4. Hold down the Return key.

Typewriter scrolling starts at about 1/4 of the way down the screen.

In theory zoom shouldn’t make a difference. The middle of the screen should not be determined by the font size, though it may be that in the code there are counter-adjustments that need to be made.


Thanks so much for giving it another go. I don’t think I mentioned anything about zoom because I wasn’t thinking about that, either, so no worries there. I can work around it for now, but I hope this is something that’s fixable.

Thanks again!