Composition mode -- cursor should be keystroke-ready immediately

When I enter composition mode, I currently have to use my mouse and click to start typing. It would make sense for the cursor to be positioned and ready to accept keystrokes immediately upon entering composition mode… probably centered on the line where it was just before composition mode was activated.


Ordinarily, and under all circumstances I can think to try, that is how it would work. Sometimes the best way to figure it out is to create a blank test project somewhere and see if that works as expected. If so, try to find what is different between the two setups that makes a difference in behaviour.

Oh, you’re right! Oh weird. It seems to be just one project… but now I noticed this:

if I copy the text of a problem note from one project to a project that didn’t have a problem before, now that project has the same problem – not just in the problem note but in every note!

Great. Perhaps then if the problem can be communicated with formatting like that, it is something we could see if you send us a sample. Try using the File ▸ Back Up ▸ Back Up To… command (with the zip compression option enabled) on a small sample project—just enough to reproduce the problem—and either attach it here, or if it has personal info, send it in to our support address, with this thread URL referenced so they know to pass it along to me.

Sure, it’s attached right here. I confirmed that the text of this note would make another new project do the same thing.

[edit: file had some personal info in trash I removed and re-uploaded… I re-tested it and copying the text of its only note still has the same effect]
atest 2018-02-21 (13.5 KB)

Thanks! No luck though, it doesn’t happen over here, and I don’t see anything peculiar with the note itself—no odd formatting like invisible tables or anything of that nature. So it is more likely some action you are taking in the project, something I’m not doing myself. It might help to describe in detail how you get from the point of a new project that works, to a project that doesn’t work right. By that I mean not only what you do, but how you do it. For example: you going into composition mode is what; using the mouse to click on the toolbar button is how.

So the project worked fine initially, but then something you did with copy and paste, perhaps in how you did it, might be the clue. I’m still not sure what it could be. I’ve even tried leaving the mouse at the very bottom of the screen, so that the control strip stays up after entering composition—but even then that doesn’t disturb the cursor. I’ve tried with the cursor in the inspector instead of the main editor—the cursor goes to the main editor in composition, even if the floating inspector is waiting and ready to be used within it.

Ok, so let me go over a really minimal version of this. This is so weird. I’m in another, basically blank project.

Currently, composition mode works correctly.

I take an untitled blank document which already exists in Drafts, and I type the following:

Thursday, February 22, 2018

(I don’t even press enter)

Now composition mode has the cursor problem.

I close the project, then open it.

Now composition mode works again.

Now I type on the line beneath the date

“10:07 am”

Before I press enter, composition mode works correctly.

I press enter. Now it doesn’t.

I close the project and re-open. It works again…

Hmm, do you have any kind of macOS level auto-correction or date detection type stuff going on, anything that might modify how the text editor works at a basic level? I’m sure you’d be seeing it with other examples, but with all of these examples involving the kind of things Apple might scan for, it made me wonder.

And while you’re at it, do take a look at any other text editing utilities you might be using. For example clipboard helpers, text expanders, third-party spell check tools—again anything that might be scanning what you type and maybe doing stuff with what you type.

Another thing I can think to try: if the cursor isn’t in the text have you tried to figure out where it is in fact? If you use the arrow keys or press the Tab key, especially with any other floating windows open or the control strip along the bottom or the main menu, do you notice the focus moving in response?

I looked at my mac-level autocorrect list and don’t see anything that would affect dates.

I did have Typinator installed but quit it and tried the whole thing again to see if that would change anything. No dice. Had an external keyboard connected, disconnected that, also no change.

I also tried figuring out where the focus was. Tabbing or typing doesn’t seem to do anything, either in the main menu, bottom control row, or if I open a quick reference window. The focus doesn’t seem to be in any of these places…

Yeah I use Typinator as well, never seen it cause issues like that; should be fine.

Another batch of potential factors: the settings in Behaviors: Composition Mode, particularly the fade and Spaces mode, but maybe even how the dock is managed. Try toggling those, and if you’re using any virtual desktop enhancements, try without that. I use TotalSpaces2 by the way—no problems here, even with the option to use a separate Space. That was the first thing I double-checked in fact, but it would be worth you checking as well in case there is a setting somewhere that is different. My use of TS2 is pretty basic—I mainly just want the old grid back and all of the animations removed, rather than Apple’s weird linear pop and push array. :slight_smile:

I don’t know why any of that would be impacted by typing in the editor a little bit first, though. That’s the weirdest part.