Composition Mode Ignores my Colours

Hey all.

I’m trying to get Composition Mode to a) have a black page with b) white text.

I can get the page to change colour, but no matter what I set the text colour to, it stays at black.

I’ve tried with image backgrounds, plain backgrounds, and texture backgrounds; no setting appears to change the actual text colour.

Please help?

Note: works FINE under OS X. This is a Windows-specific problem. Using v1.9.7.0.

Here’s the settings:

Here’s what it looks like:
composition with white text.png

That’s very odd. I just tried setting my page to black and my text to white (as you appear to have done), and set an image as my background. Everything is perfectly legible.

Are you sure you have a document with text in it loaded? I did find that If I my editor had a folder’s text section loaded, but not the text of the documents in the folder loaded, when I entered full screen mode, I just ended up with a black rectangle and a cursor. If I did that with the Draft folder loaded that way, I didn’t even get a cursor.

Try this:

Open a document in the Scrivener editor.

Select all text in the document.

Go to the Format Menu (A.6 in the Manual) and set the text color to “No Color”. (Sorry, I don’t have Scrivener in front of me, so that option is possibly called something else.)

Now go into in Full Screen mode with that document. If you can see your text, then you will need to repeat the same steps for your other documents.

Let me know if that helped!

Yep I’m sure :slight_smile:

You can see in the 2nd screenshot there that there are a few red squiggles for spelling-as-you-type suggestions. Scrivener is displaying text, it’s just doing it black on black.

I’ve had this problem before, and got tired of trying to fix it so went with a lighter background (so the default black text would be fine). As I said, this works fine on OS X.

As a possibly irrelevant detail, the slider controlling transparency doesn’t do anything either - whereas under OS X it does what you’d expect (makes the Page transparent). Here’s an example of a transparent Page with white text from OS X (which, if nothing else, should suggest I have content in there, and that I know how to adjust the settings to get a result on a different platform):

Yep that fixes it. There are some annoyances about this.

  1. This does not occur on an OS X Scrivener with the same document. For some reason OS X is correctly honouring the Page and Text settings, which I believe is the correct behaviour.
  2. There doesn’t appear to be a way to remove colour from the default editor settings, so you need to do this per document. Don’t get me wrong - you can select “no colour” in the Editor settings, but it has no effect when you apply it as the default style to the rest of your work (which makes me think it’s not actually doing anything when that option is selected).
  3. There doesn’t appear to be a way to remove colour from all documents, so if you have, let’s say, 130 documents in your project (like I do) that’s a lot of select-all going on.

This must surely be a thing that needs to be fixed :slight_smile: Or a couple of things.

Yes, it is surely annoying.

My Windows version started working like this at some point after I began working with iOScriv, and my assumption is it had something to do with that. I had to fix the text of a document over the weekend, a document I have been working without issue for a week or so on both platforms, so it is not a consistent bug (or whatever you want to call this behavior).

Perhaps you could try doing a mass update to “no color” in Scrivenings mode?

Since I swap between Windows and OS X, this might be a clue.

CTRL-A in Scrivenings Mode only selects the current document, not all of the documents :frowning: This is why I drink.

EDIT: I’ve submitted this to the Windows support email address as a possible bug.

Just to close the loop, I got a reply back from the team on this - the workaround is to use the OS X version to reset all colours to no colour.

It sounds like the OS X version leads in features/dev time (makes sense) and that an addition to the Windows version to support colour override in Composition Mode is in the works.