Composition Mode - reverting to centre.

Probably no fix, but I have found this a really irritating part of the Composition Mode.

I write a full page and continue down … all fine. Then I go back to edit and change and expand the text above, or whatever, and immediately the page jumps to place the cursor half way down the page.

Every time it happens I lose my place and have to refocus. Is this intentional ? I find it irritating and rather odd. Is there a tick box in the preferences that can make it go away ? :laughing:

Composition Mode uses Typewriter scrolling by default, so the line you’re editing stays in the centre of the screen, or wherever you’ve set it in the preferences. You can turn it off via Format > Options > Typewriter Scrolling or the shortcut Ctrl-Cmd-T. It works per-editor, so be sure to toggle it while in composition mode.

Many thanks for that :smiley: I must say that I don’t see the point of this function.

It keeps the text in the middle of the screen so that you aren’t constantly staring at the bottom of the screen while typing. It’s much less useful for editing (thus it’s only on by default in “Compose” mode). It’s one of the things many users love (it was innovated by originally), but other users want to turn off immediately. Hence it’s a setting that is easily toggled.

Having passed the 67,000 word mark in my book and not wishing to disagree with far more experienced writers, I find it odd that writers would only use Composition Mode for composing … I have always used it equally as much, or even more so, for editing and revising.

I do agree, when I am composing it is indeed nice to have the screen roll up to stay at the middle of the screen, but is it not possible to design it in some future version so that it keeps doing that when there is open space below … but when the cursor is in the middle of the text, not to do so ?

I know I can toggle it now. Still.

But what if the user decides to add several paragraphs in the middle of a piece? In that case the user is just as likely to want typing mode still on. It becomes annoying only when you are jumping about making piece-meal edits. It’s something I will think about, though, as it may be a good idea.

One of the major reasons I don’t use typewriter scrolling is this jumpiness. Could the editor scroll so as to keep the cursor on the middle line, instead of waiting for an edit to occur?

Or just not scroll when the cursor is placed let’s say more than one sentence back from the leading line … :smiley: (I don’t want much do I :blush: )