Control paragraph spacing

I am having trouble with spacing and paragraphs

My problem is that I am writing recipes. When I hit enter at the end of an ingredient I can see a paragraph sign which creates an unwanted space to the next line of text.
I have gone to preferences/formatting and project/project setting but can’t see how to get rid of the paragraph setting at the end of a line.
Any help on this?
Thank you.

I am a mere beginner with Scrivener but I have created a recipe book (with over 600 recipes) which works well for me. I created a recipe template which includes all the formatting I need for each recipe (a header, a table for the ingredients, Serves, From and Comment lines and then the start of an automatically numbered list for the process).

If you do that you can apply the relevant formatting to each part of the template (with the appropriate line spacing, etc.) and it makes entry of each new recipe very easy. Use Format > Paragraph > Line and Paragraph Spacing…, for example.

I hope that’s helpful.


If you need to be switching paragraph formats a lot, you might want to consider defining some custom paragraph styles — for example one for ingredients list items and one for directions paragraphs.


There is an item on the format toolbar that will get you to the relevant paragraph setting. It presents as a simple saying of the line spacing of the paragraph you are clicked into. So, on my toolbar it is always saying 1.1. If you click this and pick Other, you will get to a panel which will likely show you your paragraph has some positive setting for after-paragraph.

My structure is:

Chapter blurb written on folder
Recipe title(Document with subdocuments)
Ingredient list
Method description

For the ingredients I have set up a style with tabbing the way I want. If you want spacing between paragraphs in your blurb and method description, you need to set that up as part of the default “No Style”—I do that in “Project > Project Settings… > Formatting” so that such settings can apply to this project only rather than globally, but YMMV—and set up the Ingredients style to have no interline spacing.

The headings are set to the heading style I want in the compile format.

Having set up a blank recipe, I then saved it as a project template so that I can start a new recipe by selecting the chapter folder in the binder and then use “Project > New from Template” and the structure is there, though before typing the first ingredient, I set the style to “Ingredients”. Project templates do not preserve style information unless you put boilerplate text in, so you can do that and then just overwrite it when you enter the recipe, if you prefer.

Otherwise, if you don’t want to go through all that—though once it’s set up it’s very much worth it!—at the end of an ingredient line, use a line-break, Ctrl-Shift-Return—N.B. Ctrl, not Cmd! at least on my machines—instead of a paragraph break.