Converting to Default Formatting and Losing Character Styling on Paragraph Styles


I understand from the user manual that paragraph styles don’t have character style information, like boldness.

But when I go to convert a document or documents to default formatting I lose character style information on my paragraph styles.
For instance, text of a paragraph style that was a mix of bold and regular text changes to regular text. I tried checking the options and preserve checkboxes but none of them kept previous character styling. Is this intended behavior?
Or maybe I unintentionally created a style that is considered both paragraph & character? The styles at least show under Paragraph Styles, but I do notice they will reflect character styles if redefined.


This is by design.

Default formatting for new documents is set in File > Options > Editing > Formatting.

The Convert > Text to Default Formatting comments cleans out all style information and resets the text in the entire document to whatever you’ve specified as default formatting. Go to section 17.3.5 Removing Styles from Text in the manual, and see the box Get rid of them all at the bottom of the page for an explanation.

What are you trying to accomplish?


1 Like

You can tell from the dropdown styles list in the format toolbar:
Paragraph formatting styles have a pilcrow for icon;
character attributes, a little “a”;
and “all formatting” styles, both.

Screenshot styles' icons

1 Like

I don’t see that the entire document loses character styling, just the text with a paragraph style applied.
I’m trying to use paragraph styles as indentations (because unlike tabbing, the text stays at that indentation when it wraps). And I use character styling to emphasize key words.

Looks like they are only paragraph styles then, since I don’t see an ‘a’ next to the pilcrow like another paragraph style which also has text color saved.

But normally, italics and bold shouldn’t be affected.

Did you apply these off the format bar, or from the font menu ?

I am unable to reproduce.
One thing I noticed though, from your short video, is that your “no style” line behaves normally.
So, there must be something wrong with your styles.

I was able to reproduce the behavior :
Indeed, styles to which only the formatting was saved do unexpectedly behave like that.
I don’t think it is intended, as unstyled text keeps its attributes.

Meanwhile, you could redefine your styles to save all formatting. That’ll “protect” them.

1 Like

I’m not able to keep text styling by choosing all formatting. If I have some text bold, the style saves as bold, and makes the whole text bold when converting to default.

Since it seems I’m not looking past something, I’ll just accept it as something to work around. Thanks for going through this.

Redefine your pre-existing styles from a text selection containing some bold and some italic.
BACKUP YOUR PROJECT FIRST. (Or take a snapshot of all your documents.)

But no doubt this is messed up.

1 Like

I don’t believe that is a fix, at least for me.

Presumably you are making the instances of the word ‘style’ on each line bold by using the formatting tools on the menu bar or by pressing CRTL B.

What happens if you apply paragraph styles but instead of then using formatting tools to make the words bold you make and use a separate ‘bold’ character style and apply that to the instances of the word ‘style’ — do they lose their formatting as well under conversion to default formatting?

If you apply a single paragraph-and-character style to a paragraph, it formats the whole paragraph: it isn’t aware enough to know that X words should be in regular font and that X words should be in bold. So if you want to apply a paragraph style to a paragraph and to apply a separate character style to particular words in that paragraph, you can either use the formatting bar or nest a separate character style.

It seems the formatting-bar option doesn’t work as expected. But do nested styles work?


I was using ctrl-b. Applying a character style to bold instead does keep the styling after default formatting!
Thanks for the method.

1 Like

Thanks for the report, I can reproduce the issue with the conversion command not working properly when updating paragraph styles that contain ad hoc formatted text. The result of this command should essentially be equal to what you would see if you use the “No Style” command on the paragraph, and then re-applied the original style back to it, to reset all of its paragraph attributes back to the style’s settings.

I’ll get this written up, but yes in the meanwhile character styles are going to be more stable, and all around that’s a good way of working anyway.


Brilliant. As other people have confirmed, you have identified a bug; but at least this method is useable.

I couldn’t test it as I don’t have a Windows computer, so it is good to hear that you’ve tested it and proved it does work. That might even help with identifying the bug and the possible fix.

Nice use of styles. Inventive and, erm, stylish.

1 Like

Thanks for confirming and adding it.

1 Like

Your #3 style (Faded) is ¶a, both paragraph and character.

1 Like

Yeah, I learned a bit more about styles while going through this- I changed it to just be a character style since it’s only a text color change.