Copy and paste RTF formatting?

I started by generating an RTF file using a different application to get syntax highlighted code using RTF.

I then imported that into Scrivener and its worked as expected, a bunch of scrivener documents with RTF syntax highlighting.

However when I tried to copy and paste this text from one part of Scrivener to another, all the Rtf syntax highlighting is completely lost…

Is there a way to properly copy and paste RTF formatted text from one section of Scrivener to another?

Clipboard uses Plain Text. Can’t you ‘import’ the RTF in the other place?

I want to save them in my resources area and use in documents later so no that’s not very convenient and its unfortunate the clipboard can’t copy formatted RTF…very strange since its an RTF editor

Humm. Here is what I did

  1. created a new rtf file with Apple’s TextEdit app, formatted fonts and red on a word
  2. created a new Scrivener project
  3. cursor on “Research” (which I think is what you mean by “resources area”) and Menu: Files → Import → Files … and selected that new rtf file
  4. in that newly imported file, selected text that is formatted and copied to MacOS clipboard
  5. in the bank document in the Drafts part of Scrivener. Pasted from clipboard, and it worked as expected, and how I think it you expect it.

Did you do something different?

no it does not work for me. I imported RTF document, shows up fine as expected in scrivener, If I then try to copy and paste that text in scrivener to another part of scrivener, the paste is all black no formatting

If you drag text from one area of Scrivener to another it will retain its formatting.

I confirm that “drag and drop” works for me also. Only difference with that and copy/paste is that the the “drag” works like a clipboard Cut command and thus cuts the text from the source. That may not be desired in all situations. Just standard clipboard functions, actually.

1 Like

Hold down Opt as you drag; doesn’t that make a copy? I’m using my iPad at the moment so can’t check.


Simply dragging highlighted text makes a copy (in S3 for Windows).

Although @Dewdman42 hasn’t indicated his platform, he may be a Mac-user.


Are you sure about that? :thinking:

1 Like

I’m on Mac.

I will try some of the suggestions mentioned later.

I guess if nothing else I could copy the whole document instead of trying to copy the selected text.

I was also trying to do this over a remote desktop connection and want to make sure that is not the problem

That could be an important clue, particularly if the VNC client, or whatever you are using, has a clipboard sharing capability (you can copy in the virtual session and paste out into the host session seamlessly). Passing clipboards across systems, particularly different operating systems if that’s involved as well, could certainly make things more complicated.

I would look for a setting about that, and see if things work better with it turned off.

Otherwise it’s a very strange problem as the standard clipboard stores RTF, RTFD, HTML and plain-text, making it quite portable for most purposes. However within Scrivener itself it shouldn’t even be using any of those but rather its own internal pasteboard variant, which contains information not standard to any of the above, like inline annotations, image links and so forth. And it’s exactly that kind of internal clipboard that can get messed up most easily when passing pasteboard data between different computers.

I wasn’t trying to copy and paste across the connection and I was using the scrivener edit menu copy and paste instead of key commands too. But I will sit down at the actual Mac later today and try it

Well that explains it. Works perfectly from the actual Mac. doesn’t work at all from AnyDesk Remote Desktop session…even when I am using Scriveners Edit->Copy and Edit->paste menu items to do the copy and paste. somehow AnyDesk must be taking over complete control of the clipboard in some way, which is super annoying and I don’t know how to turn that off. Well anyway, that answers my question, thank you

So I guess you rant about Scrivener is malformed?

rant? There was no intention to rant anything, calm down, I was just trying to solve my problem and ask about it.

For anyone else in the future that might run into this, this is how to disable the clipboard "synchronizing’ that any desk does.


Thanks for the update and figuring out where the setting is. It’s kind of odd that they modify the client clipboard when porting it to the host as well, I do agree! Ideally it should leave the client’s pasteboard intact, and export anything it can to the host machine’s pasteboard. I’m sure that messes up more than just Scrivener, as just about anything that uses special clipboard data might fail, and lots of things do, since copy and paste within a single program often does things that would make no sense outside of the software.

Well at least that weirdness is solved. :slight_smile:

Yea I agree :point_up: wasn’t expecting that. Fine with it off. It must hijack the Apple os clipboard in some way that doesn’t translate well with some situations. Anyway just happy I can put syntax highlighted code as rtf into scripter!

1 Like