Copy paste from word, google or any app into scrivener not working

I have mini mac running macOS 14.3.1 and Scrivener 3.3.6.
Sometimes I use google doc for scenes to cut and paste into Scrivener.
When I paste into Scrivener I get a bunch of squares with question marks for characters. Same with word, or my email or any other apps.
Same with a chrome or safari brower, all current versions.
However it will paste correctly here into a topic post using this app, (is this discourse?)
I’ve rebooted. I really don’t want to use google docs or word all the time.

Any suggestions?
/jude

1 Like

Those boxes are called “tofu” (don’t ask), that usually happens when a font is missing characters. They are kind of placeholders. It’s possible the font(s) used in your online writing are embedded by the website (e.g. Google Docs), but not installed on your computer.

(The other possibility could be an encoding mismatch, e.g. one editor using UTF-8, the other something esoteric, but that’s rather unlikely these days.)

So the first step would be to look at the formatting bar in Google Docs and check the font. :thinking:

ADD: What you could also try is “Paste and Match Style” ( V) to avoid bringing over some weird formatting code.

3 Likes

thanks @November_Sierra - Did you know that as soon as you ask for tech support, the answer appears, and not from tech support…

The problem is that whenever I paste, the font style defaults to .LastResort The text was always there!
Paste and match style doesn’t work, I tried various was of inserting the text.

If I highlight the text block and reset it to Helvetica or something else it is magically revealed. There must be a default paste font setting, do you know where that is?
facepalm! I lost hours of my life. Highlighting and resetting font over and over will do for now.

1 Like

Yeah, that’s always the way it works. :smile:

So, let’s say you create a new Scrivener text (or to be on the safe side: even a new project). If you “Paste and Match Style” into that: Same problem? Because what enters Scrivener at this point should be plain text, no fonts and stuff. :thinking:

I have been having exactly the same issue and found this reply through a search for .lastreport Scrivener. A bit more detail: the Google doc shows as “Arial” (default font) but when I copy/paste (command-V) into Scrivener, it gives me the tofu (love that name thanks).

I did try the Paste and Match Style command and it worked. Previously I’d just highlighted all the tofu and removed formatting.

This seems like a relatively new glitch, maybe related to the last update?

Thanks for the help/info.

PS Should’ve added that the tofu shows that weird “.lastreport” under fonts.

.LastResort is a deep fallback for cases where no fonts on the system can display the characters. I have seen this problem myself, though on iOS, where if the font I wanted wasn’t installed it would jump to this instead of Helvetica as it should. Selecting all of the text and changing the font fixed it. My only guess is that the bug is misdirecting the fallback behaviour for missing fonts in some cases, to something it normally wouldn’t use for a missing font at all.

This is all well beneath Scrivener’s code, so it might more be acting at the messenger here for a Mac bug than the actual culprit. Additionally, by “missing font” we must think of that more as: missing the font the clipboard requests. There are multiple ways to talk about fonts inside of rich text formatting, and the way it is asking for Arial might not be how Scrivener would recognise that request. You see this problem a lot in word processors because there are no universal standards for how fonts should be addressed.

Something to check:

  1. Open the free TextEdit.app that comes with your Mac.
  2. Use the Format ▸ Wrap to Page menu command. This will force TextEdit to use the same version of the text engine that Scrivener uses.
  3. Perform a fresh copy and paste test from the original website text.

If you see it there as well, then there is nothing we can do about it, it’s a Mac bug. If that does work, then we’ll have to see if there is some way to blindly fix it. These are difficult to fix though, because like I say this behaviour happens “underneath” Scrivener’s programming. There is no way to debug that kind of behaviour, leaving the only option to blindly try removing chunks of code.

You can do similar yourself by the way: try creating a new “Blank” project in a throw-away location like Downloads, and without touching the window, editor settings or fonts, paste from a fresh copy. Does that work? If so, look at what editor settings you use that Blank does not. Anything at all might be a factor, from invisible characters showing, to the line numbering tool, to page view.


I should add: in most cases you’ll get the best result by exporting as .rtf / .docx from Docs, and importing the file into Scrivener. Copy and paste from browsers (especially), and even other word processors, has long been the least reliable way to move data around. I don’t know if it will fix this, but you’ll likely get better formatting all around.

1 Like

Thanks for all the details. I tried the TextEdit test and sure enough, it was tofu there too. Since this is not a huge issue for me, I’ll just use the Paste and Match Style workaround suggested earlier.

Appreciate the prompt and detailed response!

2 Likes

If plain text paste is all you need, then copy and paste is good enough!

Export/import may be more valuable for complex formatting you wouldn’t want to lose, such as footnotes, comments, images, tables, links and so forth.

I just use this to move quotes/emails into Scrivener. Complex formatting = compile, my least favorite part of the program! :slight_smile: Thx