Copy-pasted footnotes end up in the body


Since I updated to, I have a problem with copy-paste. If I copy text that contains a footnote, that note will be expanded into the body, surrounded by two square brackets. [Like this.] This is seriously impeding my workflow and I hope there’s a fix for it.

Hi, p7389, and welcome to the forum!

You can paste text two ways in Scrivener:

Paste (Ctrl-V) - regular paste, will keep the source format for the pasted text.

Paste and Match Style (Ctrl-Shift-V) - will only paste the text, eliminating the source format. If the source text has a footnote, it gets converted into this: [footnote text]

This behaviour has not changed on 1.8.5, so unless you’ve changed the default keyboard shorcuts, using regular Ctrl-V should do the trick.

Hope this helps!

I have not changed my key bindings, and both ctrl-v and ctrl-shift-v produces the same result (I was aware of the distinction; I use it a fair amount, in fact).

Edit: I might have solved it? Or it solved itself? Maybe sticky keys was activated or something?