Couple of things I've noticed...

Hi there,

I’m on macOS 10.14.5, and I’m running Scrivener 31.2 (10885). And I’ve noticed some odd behaviors.

  1. Scrivener doesn’t remember whether it was in full-screen mode between launches.
  2. Editors don’t remember their correct sizes between launches.
  3. The Binder doesn’t remember it’s correct size between launches or between full-screen sessions.

Are there any workarounds to this?

—Andy H.

I get hit with these too (the first and last).

The Binder width is retained when you quit non full screen. It seems to get messed up when you quit from full screen; which then reopens in non full screen, and you have to fix the Binder width again.

The workaround is to exit full screen before exiting Scrivener – I always forget.

At least, I think that’s going on. It’s odd, because Scapple remembers full screen by project.

  1. Yeah, it used to do that, but then a bug introduced in some old version of Mac OS X forced us to remove it. The bug causes crashing somewhere deep in the animation code that Apple uses to switch Spaces (of all things). It very likely has to do with the complexity of the Scrivener window, which is another universe from simple things like Scapple or even Pages.
  2. Not sure about that one—I’ve never seen that happen, except in cases where the software hasn’t shut down cleanly the last time. When a project is closed normally, one of the last things it does is record your window layout for the next time. So persistently losing your window view settings could indicate a deeper problem.
  3. That on the other hand is as far as I’m aware a known limitation, but it’s been ages since I’ve looked into that.

By the way, have you considered using a saved Layout for all of this? Open your project, and instead of using the generic Full Screen command, use Window ▸ Layouts ▸ Whatever and all of this stuff gets set up for you. Just be sure to save the Layout from Full Screen—that way the software will switch into that mode as part of what it does.

And if you mainly prefer one look for all of your projects, consider the “Use selected layout when entering full screen” option, in the gear menu of the Manage Layouts window. Then you can go back to using the generic command.

Here is the result I get every single I load Full Screen mode with the described setup:

[size=80]Very wide binder, narrow left editor, remainder for text editing.[/size]

Please remember binder width,when I quit Scrivener in fullscreen.
It’s annoying to operate one by one.
It’s not smart.

If Scrivener automatically exit full screen before quitting when I quit Scrivener (I use always “command+Q”), I can safely forget exit full screen before quitting Scrivener.

Do you use Keyboard Maestro? It’s a very useful addition to Scrivener. You can just build a macro that will fire when you press Cmd-Q, and set it up to exit full screen and then quit automatically.

Thank you popcornflix

I wrote AppleScript (exit full screen and then quit automatically). And I assigned it to “command+Q” by Alfred.