Cover Image Not Showing up in Compile

I have created many books with Scrivener and now I cannot get cover image to display when I compile as mobi.
The book in the Kindle library displays with only written title and author.
In compile in cover page tab I only get option “No cover Image” or “First Image in Front Matter Folder”.
I get this whether I include cover matter or not.

I have not been able to do this since upgrading from 2.0 to 3.0 > Is this a factor or did I disable something in preferences?

Please help.

Those are the two standard options that appear under the Cover Image tab of the Compiler if you’re using one of Scrivener’s templates that comes with a Front Matter folder. Do you have your Cover Page image in the Front Matter folder? If so, you should see any images that are in that Front Matter folder appear as an option in the dropdown. If not, you’ll want to locate that folder in the binder and add your Cover Image there (you’ll also need to move your other Front Matter to that folder if you had manually arranged it in the Manuscript folder, which will also help with page and chapter numbering) and make sure you have “Add Front Matter” and the correct folder selected on the main Compile tab.