Crash from Dictionary Panel

I just had my Scrivener project crash on me three times in a row, but only after I used the Contextual Menu to look up a word using the Dictionary pop-up panel. I took a look through the console, and noticed that around the time of each crash, my console recorded an error relating to a file in my ~/Library/Contentual Menu Items/ folder, namely “BigCat.plugin” which is something I installed quickly years ago, promptly stopped using, and forgot about it.

Obviously, this has nothing to do with Scrivener, but since it happened in Scrivener, I figured I’d relate it here in case someone else had a similar issue.

All you have to do is delete the plugin, restart Scrivener, and you’re good to go.

Well, it’s now the next night, and I’m having the same issue again. Since I deleted the BigCat plugin, that obviously wasn’t it.

The issue is definitely attached to the Dictionary pop-up panel, though. I’ll try to recreate it step-by-step in a second, but just so you know, Keith, Activity Monitor is telling me that Scrivener (which is frozen with the pop-up panel open) is using 98% of my CPU, and while the OS isn’t telling me that Scrivener is frozen, I can’t click anything in it, or escape out of the Full Screen view (I can, however, get the menu bar to slide down, though I can’t click on anything).

I looked at Console, but nothing is showing up for Scrivener (not at the time of the hang anyway).

The project is 24.9 MB and contains everything from text files to multipage PDFs to image files to URLs.

I’m gonna Force Quit and try to recreate the issue.

Okay, so I opened the file, right-clicked on a word to “Look up in Dictionary” and everything was fine (this is in the editor, not full-screen view). Then I did it again (still in the editor), and tried scrolling through the definition in the dictionary panel, and THAT’S when it hangs up. Not when the panel comes up, but when you scroll in it.

Again, nothing showed up in Console from Scrivener on this. I’m wondering if its Growl though. I’m getting an error in the Console that says this:

9/1/09 9:53:20 PM	GrowlHelperApp[162]	*** __NSAutoreleaseNoPool(): Object 0x15e0d830 of class NSCFDictionary autoreleased with no pool in place - just leaking

I’ll try turning off Growl and see what happens.

Nope, that didn’t work. Same issue.

Let me try it in TextEdit, to see if it’s the panel itself, or something in the connection with Scrivener.

Nope. Works fine there, so it’s Scrivener only I guess.

Keith, would sending a sample of the process from Activity Monitor help? Or is there somewhere else I can look besides Console for some messages? Also, is anyone else having this issue, or just me?

I guess I should try it on another project first, huh? See if that’s it?

Yep, happened in a different project too, this one only 3.3 MB. And again, it only crashes when I scroll in the panel.

Any thoughts? Can you recreate the bug?

It’s not a huge deal at the moment, because I can change the preference within to have the contextual menu “Open Dictionary application” rather than the panel, and everything works fine from there, but I thought you’d like to know.

Let me know if you need me to try anything else.

Oh, I should probably mention that I’m running Scrivener 1.52 on Snow Leopard using a Mac mini 2 GHz Intel Core 2 Duo with 1 GB of RAM.

This isn’t really related, but since it concerns the Scrivener contextual menu, selected words and Snow Leopard, I thought I’d post it: I had an issue after my Snow Leopard upgrade in which Scrivener wasn’t letting me add words to the dictionary from the contextual menu. I realised after a while that Snow Leopard had killed my default language settings. Re-selecting my language gave me access to my custom dictionary again.

Hey Keith,

I just updated to 1.53, and I’m still getting the issue with the Dictionary Panel. Any thoughts?


Hi Kyle,

I’m afraid that I can’t reproduce it. Is anyone else seeing this?

All the best,

The first time ever I started the Dictionary (from the Dock) under Snow Leopard the Mac went to sleep.

Since then I have used it several times and it crashed once but not more.

This happened without Scrivener even running. So it is clearly a Dictionary issue.

EDIT: As there have been a lot of font issues with Snow Leopard maybe this is one too. I’d recommend you to check the font you are using for the Dictionary, Kyle.


Thanks for the help, but the issue is only occurring when I used the Dictionary panel in Scrivener. When I use it with other apps (Mail, TextWrangler, etc.), it works fine.

I tried deleted my Dictionary preferences file, but unfortunately, that didn’t fix anything. I’ve spent the last 20 minutes on Google trying to see if I can find anyone else with the same issue, but nothing’s coming up. Must be something specific to my machine.

Oh well.

I think this is your problem

Thanks for trying Wock, but I don’t think that’s it. I don’t have any Contextual Menu Items installed, either in my system Library or my user Library. I had the BigCat one, but I deleted that back at the beginning of this process.

But you gave me an idea. I should try using Scrivener under a different user account on my computer. If the Dictionary panel works fine, that’ll probably mean the issue is somewhere in my User Library. I won’t know where exactly, but it’ll be a start :slight_smile:

I’ll give it a try later tonight.

I was thinking because of this first line you stated…

I just had my Scrivener project crash on me three times in a row, but only after I used the Contextual Menu to look up a word using the Dictionary pop-up panel.

Hi, sorry, could you give the exact step-by-step down of how to reproduce this? I’m not sure if you mean you did ctrl-D on a word and the used the menu, or if you just used the menu, or exactly what I need to see it…

I just installed the OS X 10.6.1 update, and the issue went away.

So…it’s fixed…I guess…?

If it crops back up, I’ll be sure to let you know.

Sounds promising - I like it when OS updates fix things! Let me know if it starts up again, though.