Crash opening ANY file (Illegal NSTableView data source?)

Using Scrivener 1.03. Was working fine on a PowerMac G4, working on many projects.
I transferred all files to a new MacBook Pro i purchased, using Apple’s Migration Assistant). All is well, except Scrivener.

I can open Scrivener directly. But if I try to open any project, or double-click on a project, Scrivener immediately crashes and the Finder dislays the “unexpectedly quit” box.
If I create a new project, it crashes upon clicking “create.”

I have run disk util, run /sbin/fsck -fy, deleted Scrivener and all associated files (using AppDelete) and reinstalled. Re-entered serial nmber. Same behavior.
I downloaded the beta and tried that. Crashed upon rebuilding the project.

This sounds like a problem on my end, since I cannot find anything exactly like it on the forums. I hope someone can help…my writing has come to a screeching halt. Thanks.

Here is an example of the console log:
===== Saturday 28 July 2007 11:56:56 America/Los_Angeles =====
2007-07-28 11:57:06.424 Scrivener[1478] *** Illegal NSTableView data source (<SCRSearchResultsController: 0x4d9aa0>[object class: SCRBinderDocument, number of selected objects: 0]). Must implement numberOfRowsInTableView: and tableView:objectValueForTableColumn:row:
Jul 28 11:57:07 PB-G4-de-Markus crashdump[1479]: Scrivener crashed
Jul 28 11:57:07 PB-G4-de-Markus crashdump[1479]: crash report written to: /Users/Mark/Library/Logs/CrashReporter/Scrivener.crash.log

Working on previous posts, try reinstalling Quicktime. This can really play havoc with Scrivener if it’s not 100% clean. Give it a try before attempting anything more invasive. :wink:

Yep, I would say this is almost 100% a QuickTime issue. The Illegal Data Source issue is actually a non-issue. It’s a bug in Tiger whereby Tiger issues a warning about something that is categorically, absolutely okay (but something that wasn’t available on Panther, and they didn’t take the warning out of Tiger).

That is not what is causing the crashing issue. The Migration Assistant is notoriously buggy, and I regularly get e-mails and posts from people who have used it only to find that Scrivener no longer works - the reason being that Migration Assistant somehow screws up the QuickTime installation, upon which Scrivener relies. Try opening QuickTime - I bet that crashes too.

Just reinstall QuickTime and everything should be peachy.


Incidentally, once you’re up and running again, do try upgrading from 1.03 to the latest beta (1.06). Keith really has produced an evolving masterpiece of robust usability, and 1.06 is the release candidate for 1.1. Actually, it IS 1.1, minus the updated help file. As my daughter would say, “Scrivener rocks!” 8)

Yes, it was QT. I ran Software Update, and now Scrivener works like a charm.

Thank you all for the quick response!

I’ll go ahead and download the beta on your recommendation, Juddbert, then get back to writing. :laughing: