Crash when undoing Delete/ move to trash

Hi, Scrivener is great and hasn’t given me any problems writing my dissertation… until today. Let me try and recreate what I think caused it.

I had been typing in one text doc for an hour. I opened/showed the binder and clicked on another doc and trashed it. This doc was empty: just a title being used as a placeholder. I decided that I wanted to keep this placeholder doc around a little longer so I did a Cmd+Z to get it back and Scrivenner crashed. Oh, mama. So I got the crash message which asked if I wanted to reopen, which I did. Scrivener tried to open back up but crashed again. Then again. I had thankfully just backed up my .scriv project so I double-clicked that .scriv file and this opened, Scrivener has been okay since. So, it’s as if the original document was corrupted. I can send you the original if that helps.

So, to recreate (as I understand what happened): trash a doc and then do a cmd+Z to try and bring it back to the binder.

Anyway, that was scary but Scrivener is still the best, most stable writing program I’ve used thus far: except maybe TextEdit which isn’t much help for this kind of writing. I hope that having to redo those 250 words made for a better text. Not a bitter text!

Thanks for all the great work.

I’m on a MacBook = Intel.

I just tried that exact sequence and it didn’t crash - it just gave me an error beep when I hit cmd-Z. I’m on a G3, though, maybe that’s an Intel-specific problem?

What version are you using? 1.03 or the latest 1.1 beta from the Beta Testing forum?