Crashed on my old Mac running 10.10.05. Resinstalls not working. Please HELP!

I’m using an oldi-ish Macbook that runs OSX Yosemite 10.10.05, and I’ve been using Scrivener for a few months. I’ve had no trouble except the occasional lag in opening/saving a project. But yesterday was the first time it fully crashed on me (and then asked if I wanted to ‘send a repoort’).

This had never happened before, and there was nothing ‘suspicious’ about the project I was working on - i.e. it was rather empty with no questionable attachments. But Scrivener refused to open again. Each time it popped up with the, ‘quit unexcpectedly, ignore/report/details’ window. It would then continue to glitch if I clicked, ‘report’, not letting me send it through before crashing yet again.

I honestly don’t remember what version of Scrivener I was using initially (I downloaded it straight from the site after purchse, and it worked fine with my OSX] other than it being 'Regular Licence '. All I know is that my receipt says I purcahsed it 8/18/2017.

I googled for help yesterday, and others with a similar crash-problem (on an old mac) recieved advice to re-install, and that that actually helped. But re-install didn’t work, so I deleted the app and re-downloaded it, re-installed it - BUT I realised the newest version, ‘Scrivener 3’, was incompatible with my mac OSX. So I then cycled back through each update - downloading each one in turn ( ), deleting the previous download (and removing it from my trash) before trying to install the next one. I got as far back as 2.5, which managed to open the inital Scrivener window - choosing projects/template - before crashing when it tried to open/duplicate a project. It also wouldn’t let me start a new project.

  • I also paused Dropbox sync on my mac while I tried these re-installs, thinking maybe the sync was messing things up. But it didn’t seem to make a difference.

So I was either faced with the, ‘quit unexpectedly’ window, OR it told me that version ‘wasn’t compatible’ with my OSX.

I’m not sure what to do here, guys. :cry:

I just need help figuring out a couple of things:
which version IS compatible with my OSX 10.10.05 Yosemite (please link me to the download that doesn’t contain any significant bugs!)
why did it crash in the first place??

I’ve read a few theories that Dropbox is somehow the culprit - syncing more than one copy of my Scrivener project files? It wasn’t clear. I do use Dropbox as my sync-preference, with a local folder kept on my Mac. And once or twice when opening a project I was prompted to ‘save a copy’ or ‘continue’ and risk overriding, as there was a duplicate in my files…? Honestly, I don’t know how that happened with some projects and not others, seeing as how everything is saved to the same folder and I just hit ‘save’ before exiting any story project.

…I was just starting to gear up for a few important writing projects… and NOW THIS!
So I’m stressed, I’m confused, I’m smad. :open_mouth: :angry: :cry:

If I can’t figure out why it crashed and why it now refuses to work on my mac, I may have to abandon Scrivener and use another program… I hear Ulysses is good? The monthly fee is a pain though - especially for a broke writer, especially since I already dished out over $60 for Scrivener (Australian).

I just really really need to fix this. I need to be able to sit down and write and not worry if my files are gonna crash or even disappear.
(Is there a way to view Scrivener files if I can’t get Scrivener working again? I would like to export the story notes somehow… is there a way to convert a Scrivener project file??)

  • Sorry if I went off-topic or rambled a bit. I just wanted to give as much relevent detail as possible. :blush:

I’d try moving the preference files out of your library, then trying Scrivener again. If you just delete the application from the Applications folder the preferences remain and they may well have been corrupted. In Finder, hold down the Opt key, click the “Go” menu and you’ll see Library, choose that, then scroll down and choose Preferences. Look for


N.B. they may say …scrivener2… or some variant, as you’re looking at a much older version than mine. Drag them off to your desktop so that if the preferences are not the problem, you can reinstate them.

When you’ve moved the preference files, try opening Scrivener again. If that works, you’ll have to redo all your preferences, I’m afraid, and trash the old ones. And you’ll have to open your projects from File > Open or by double clicking them in a finder window.

Another thing you can try: if you hold down the Shift key as you open Scrivener, it won’t try to load any project as it opens which may eliminate any issues with projects, If that works, you can try opening your projects to see which one is causing the problem. Then email Lit&Lat support about it.

The other thing you can try is to make a new trial account on your computer and see if Scrivener opens in that account. If it does, you’ll need to go back and trouble-shoot your main account as above.

HTH :slight_smile:



The best version of Scrivener for your machine is 2.9.

Yes, it is possible to extract your work from a project without using Scrivener. It’s time consuming and tedious, but it can be done. You should be able to get back on track without resorting to such extreme measures. (Mark’s advice about resetting your preferences file is good.)

Why did it crash? Impossible to say without looking at the crash report.


This worked!! :mrgreen: I’m so happy, I can’t even… :laughing:

I never would have figured this out on my own, so thankyou so much!
I moved the preferences and reinstalled 2.9 (thankyou Katherine!) which seems to be the version I was working with, going by the date.
I did have to rejigger my preferences atferward, but honestly that was no biggie, and considering my files were intact I’m simply over the moon!

It’s good to hear that Scrivener files can be accessed (though I won’t need to now) even if it does take considerable effort. It’s just reassuring, is all. :wink:

If - Chuck forbid - it does crash again, I’ll try to be mindful of every possible screwy element of my project (just in case It crashes while trying to send the report) and so I’ll be aware of what to avoid for future projects.

(Oh my, and I checked out Ulysses last night - a monthly fee for doing less than what TextEdit does for free on my mac?? No thankyou. Second crisis averted.)

Thankyou SO much guys!! I am indeed, back on track. :mrgreen:

Glad you’re up and running again.