Crashing on Compile

Scrivener is crashing on selecting compile. The crash occurs regardless of the output file type.

Scrivener information:

Version: (1812589) 64-bit - 18 Oct 2022

Windows information:

|Edition|Windows 10 Enterprise|
|Installed on|‎2/‎11/‎2022|
|OS build|19042.2130|
|Experience|Windows Feature Experience Pack 120.2212.4180.0|

|Processor|Intel(R) Core™ i5-8500 CPU @ 3.00GHz 3.00 GHz|
|Installed RAM|8.00 GB (7.80 GB usable)|
|System type|64-bit operating system, x64-based processor|

Could anyone please assist? Scrivener is not usable for me at this time.

Very respectfully,

Try white-listing Scrivener in your antivirus.

You mean during the compile process, right ?

Hello Vincent,

Thank you so much for writing me.

When I click the compile button, the application closes completely. It doesn’t appear that the app runs a compile process at all.

Very respectfully,

1 Like

Try compiling a single document :


The idea being to see if there is a specific document in your project that crashes the compiler for some reason.
Pick a document randomly. If it works, try with another, a couple of times like that.
If Scrivener doesn’t crash, we’ll know something is wrong somewhere in your project, and can start looking for it.
If it does crash at some point, make sure you remember which document it is you were compiling.

If it crashes no matter what, at least try rebooting your computer. (?)

You may also try compiling using a different compile format. (?)

Hello Vincent,

Thank you again!

So, I did the restart, then I tried to compile a single page in the first project (it crashed). I then tried to compile a single page in a different project, Scrivener crashed again. the progress bar on the compilation process gets to approximately 33% and then the crash happens.

I’ll try on a different computer later tonight as well.

Very respectfully,

For what it’s worth, I think the error is in where the documents were saved… a shared drive vs. the installed drive on the computer… Which is a little puzzling because on my home computer, I use dropbox… More troubleshooting to follow.

This happens to me, too. About every 2nd or 3rd compile attempt it will just shut down.

Hi, I’ve been having this issue too. I think I just figured it out. I got it working again, but since it was, literally, just now, I can’t guarantee that it’s a long-term solution. I’m willing to bet it is though.

I’m on licensed Scrivener v3.1.4 on Windows 10.

Here’s what I tried that DIDN’T work:

  • Rolling back to previous versions. I tried uninstalling and reinstalling 3.1.4. Then I tried 3.1.3 and 3.1.2.
  • Creating a new blank project and dragging and dropping the info from the non-working binder to the new one.
  • Removing all labels from the binder.
  • Creating a new project folder (a.k.a. save location) under a new name and copying all the files from the old project into it, and renaming the scrivx file too.
  • Compiling different portions of the project to see if only certain parts were breaking it.
  • Repeatedly compiling in hopes that it would randomly, magically, work again.

Then, I had the brainstorm to try a different project to see if it crashed too. It did NOT, so it had to be something project-specific, not Scrivener-specific.

Here’s what DID work:

  • First, I closed the project.
  • Then, I went to the Windows Explorer project folder, then the settings folder. (e.g. C:\Project Folder.scriv\Settings)
  • Then, I renamed “compile.xml” to “compile_OLD.xml”. I didn’t want to delete it, just in case.
  • Then, I reopened the file and tried compiling again, and it worked! Woo hoo!

The file must have been corrupted somehow. I hope this helps.


Is there any other process running on your computer that could be accessing or otherwise opening/messing-with your Scrivener files? For example, a sync service (One Drive, Dropbox, etc.), or aggressive anti-virus, backup software, … ? Or perhaps there is some sort of issue with the hard disk? (grasping, I know).

I do use Goodsync to sync my data between 3 PCs. I’ve never had an issue before, however, my USB has been loose in the slot recently so it may be confusing Goodsync if the sync gets broken in the middle by the USB disconnecting by accident. Still, the file rename worked so I’m happy.

You are using a USB stick, swapping between the three machines, to “sync” them?

If yes, that’s probably the root cause of the corruption. USB drives eventually fail, especially when used frequently. I learned that years ago after suffering file corruption. I sync with sync services now (Synology Drive and internet services Dropbox and Google Drive).

1 Like

Indeed. Best practice would be to save to local drive, then copy the project folder to USB to transfer to a different computer. Then vice versa.

I have worn out USB ports on devices, but these were chargers for criminally cheap phones and earbuds. Never seen it happen to a USB drive personally, so now I have a new thing to worry about.

From my readings (over a long time, so maybe in this century things better), but USB connectors sometimes get worn out, or the storage media gets corrupted. Who knows. With USB “sticks”, when dead, people just throw them away and get another out of the drawer.

I just don’ RELY on them. Useful when working, and if not … throw away and use another.

My USB is used primarily for backup of files that I like to carry with me or don’t want to lose. Goodsync automatically syncs to the source folders on my PC. I also have backup drives in a hub so I’m not worried about losing much data. That’s what the backups are for. I’ve been using Goodsync for many years and have never had too much issue with it.

I posted to tell people how to fix the problem not why I had the problem. That said, you’re likely right on the syncing being the issue and corrupting the file. My USB slot on my passthrough keyboard has been where the connection issues are and may have broken a sync during updating files. Who knows? I’m just happy it’s working again and it was an easy fix.

1 Like

Wonderful. Now I can’t compile AT ALL.

Scrivener is now completely useless for me…

5-minute update:

I tried other files, and they compiled fine, then went back to the first and it worked. I’ve been having a lot of trouble getting compile to work on any project, but once it works, it seems to work on all of them. For a while.

This is intolerable…

Hi there @clancyweeks,

As this involves crashing, you may also want to contact L&L support directly for this one. They’ll probably request a sample of your project to see if they can replicate the issue.

After you submit the bug report form, you should receive a nearly immediate auto-reply via email, and then a human response in a day or two. Be sure to check your spam folder.


1 Like

Nice typewriter avatar JimRac, is that an Underwood 1947 S-11?

Lol, thanks! I’d love to be able to say that I owned the actual typewriter, but it’s just an image I found that spoke to me. :innocent:

A Google Lens search leads me to this model:

Presumably the seller knew what they had, so it seems like that’s the one. Then again, I’m no expert, so perhaps I’m missing some differences in the photos.

Regardless, what a beefy machine!

BTW, thanks for the question, I never thought to actually try to figure out what model it was!



I have an S-11… I keep a sheet of paper in it, with the title of the book I am working on typed centered on the page… It’s a focus thing.

Thanks for the correspondence. Have a great day!