Crashing/Spinning wheel on all projects even blank templates

I’m running:
MacOX 14.3.1 on a 2020 MacAir M1
Scrivener v 3.3.6

Any suggestions on how to solve a continuing spinning wheel of death issue. It started happening infrequently with a medium sized project (500,000 words of text, no images, maybe 70 folders in the binder). And then was happening with a smaller project (200K words, no text, 30 folders) and in all cases it would happen randomly, just during normal use of navigating text.

Now I can’t open a project and use it for more than a minute before the wheel kicks in. I Force Quit the app and tried to open a blank template and as soon as I try to navigate the binder it goes right into it.

All files are stored locally.

1 Like

Could be your antivirus doing that.
Whitelist Scrivener in its options.

I don’t have any anti-virus software running on the machine.

What else is running on the system?

I’ve been recreating this problem over and over with only Finder and Scrivener running after a fresh restart and a fresh shut down/reboot.

1 Like

Please reset Scrivener’s Preferences file, as explained here:

ok thanks. I’ll try this and report back if that doesn’t do the trick.

I have the same problem. MacAir, on Big Sur. Is there a simpler solution?

Without more information, I have no idea.

What version of Scrivener? How big is the project? Is it stored locally or with a cloud service? What else is running on the system?

This did seem to do the trick. No spinning wheels since.

Scrivener 3.3.6. Cloud. Firefox. But even if I close everything and restart my computer, it happens.

Make sure the project is configured to be available offline. If Scrivener has to download the project in order to open it, that can cause a substantial delay. (And can also lead to other issues.)

That is good thinking and it began to occur to me as soon as you asked whether it was local or in the cloud. Thank you.

But how do I make sure it is configured to available offline? :slight_smile:

That depends on the service you’re using. Consult their documentation.

Generally speaking, though, look for a “cloud” icon in Finder, or right-click the project and look for a “make available offline” command.

I may have a clue that I have explored myself and that seems to alleviate the problem. Automatic backups were set to a folder in my Mac’s “Library”, which is backed up regularly to iCloud. Changing the backup folder path on a local volume seems to resolve the issue.

1 Like