Crashing When Clicking Research Folder - Version:

I have several things in my research folder, primarily drag and drop web links, and Scrivener crashes with each click of the folder name (Research) or the items within. No data loss that I can tell, but it doesn’t restart in my last position.

I see this has been a problem in the past, but I haven’t found a fix for Windows 10, V 3.0.

If I missed it, please let me know.

This sort of behavior has happened in the past and seemed to be caused by a bad link or document in the research folder. If you start a new project (nothing in the research folder), do you have the same issue? If not, now go back to the problem project and, rather than clicking on the research folder name, click on the expander next to it to let you view the content name in the folder while in the binder. You can then click each document/web link to see which one causes the crash - move that one to the trash folder - then check the others. Eventually, you will find the problem and the research folder can be opened in corkboard, scrivenings, or outline view.

1 Like

It seems to happen even in a new project, but only when using web links.

Steps to duplicate:

– Create New Project (in my case, Fiction)
– Under Research, drag a web link and drop it on the “Research” folder that was created by default.
– Link Imports as expected (though why can’t I edit the title upon import!)
– Click on the item Under Research
– Scrivener Closes instantly

I also tried putting my current project Research folder in Outline mode, and it crashed.
When I tried it the 2nd time, it didn’t crash until I tried to select the first item.
The 3rd time I was able to click the first item (still in outline mode) without it crashing, but it crashed on clicking the NEXT item.

I’ll work through them and see how far I get, but I don’t think the problem lies in a corrupted research item since the brand new project crashed with a new link.

Question: Are all of your links from the same domain?

I’ve not been able to replicate your issue with links from and I’m curious as to whether it might be an issue with attempting to render specific websites.

No, in my original project I used several scientific research journals and websites as well as regular documents. When I did a test in the new project, I grabbed a random link from my publisher’s website.

It’s a while since I ever loaded a weblink into the research folder (never in Scriv 3). So I just created two new projects, 1 non-fiction and 1 fiction-novel. Then I dragged this thread into the research folders of both projects.
I was able to click and access the research folder and the website without any problem.
Could it be connected with the browser you use ? My tests were with Firefox.