Creating flush left paragraphs

Though I am impressed with Scrivener I am still learning it and I have found the learning curve to be steeper than I thought.

A few simple things would help speed me on my way to utilizing it:

  • How do you create flush left paragraphs as the default paragraph style, in lieu of the hanging indent style that seems the default? I have tried \Project\Text Preferences and adjusted the ruler in there, but alas, to no effect.

  • How do get the 2nd line of a numbered list to line up under the text of the first line (i.e. a space to the right of the number).

  • How can I get a Section Title without an extra line between that and the paragraph text below it. I was able to get the Section Title by going into Compile and then Format As: Custom - and then by clicking on the Formatting Option on the left - and then by clicking on the Level 1+ - and then by “Level Settings” (shesh! did I say steep learning curve!). See the attachment. Though this looks right in the preview, it actually compiles with a carriage return between this Section Title and the paragraph - which I don’t want.

Thanking you in advance,

Okay, I assume you are basically asking all of this in the framework of compilation—i.e. what you want the final product to look like, regardless of what you see in the editor (or maybe as an embellishment to what you see). Compile override formatting is a way of applying a look and feel to an output without impacting the internal editing or forcing you to work in a particular fashion. The main reason I am stating all of this up front is that I want to make sure that is what you are going for. Some of the stuff you reference in your message would only impact Compile if you have format overriding turned off—and then you would be working more like a traditional word processor that is WYSIWYG.

Now, your screenshot does indicate that is how you’ve got things set up. That little checkbox at the top “Override text and notes formatting” is disabled—which means that whatever RTF styling you’ve used while typing will be used in the final result, even if it all wildly deviates from one another. The compiler will make no attempt to clean any of this up for you. If you do check that off, you’ll notice the greyed out paragraph below will turn black—indicating that what you see in this mock editor is now more representative of what the final output will look like.

So to answer your first question: I think you’ve got the rudiments of ruler handling figured out, because the example paragraph already is left block aligned. It’s just, as I pointed out, grey—so it’s not actually doing anything right now.

The [b]Project/Text Preferences...[/b] and the main application Formatting preferences both impact the editor default—what Scrivener looks like while you type. The latter impacts all new items that you create in any project. The former only changes the default for one single project—so you can have a special look & feel for one project and not another if you so wish. Generally you don’t need that option but it can sometimes come in handy. It’s a more advance tool.

But like I say, unless you leave that override checkbox off, what you see in the editor is often nothing like what you get when you compile; so you may base those settings on your aesthetic choice.

Hanging indents are not a default look in Scrivener, so they might have come in via an imported document or pasted material. By hanging indents, just to be clear, I mean the first line of a paragraph is leftward of the rest of the paragraph, so that it “hangs” over a blank space. The reverse of that is far more traditional in book typesetting, where the first line is offset rightward of the rest of the paragraph, usually by a 1/4 or 1/2 inch.

I’m not sure what you mean here. Are you getting numbered lists where the second item in the list is offset from the first? The only thing I can think of that might be causing that is if the first line isn’t actually a numbered part of the list—and just looks like it—perhaps pasted in from another source?

Is this in the editor or after compiling?

Difficult to say. The text items in the binder might have a carriage return at the top of the file; or your formatting in the editor might use pre-paragraph spacing instead of post-paragraph spacing. Since you aren’t using the override, there are more potential variables here.

First, thanks for the reply, but I have to say Scrivener has the be the most FRUSTRATING software program I have ever used!

I tried what you suggested by setting the formatting in the preference for new documents and also for this project as follows:

  • Body should be: Gill Sans, 12pt, flush left, Regular text

  • Title should be: Gill Sans, 20 pt, centered, Bold

I will then create the exact same formatting in the Project\Text Preferences.

Then, I will Select All the text using Select All and the Scrivener that all the text is of type Body. Thereafter I will select only the title line and say that is of type Title.

Finally, I will Select All again and use the Document\Convert\Formatting to Default Text Styles - then the unbelievable frustration kicks in :angry: - as Scrivener will reset the styles and the document I just painstaking modified back to some default style of it’s own, so that the following happens:

  • Body is now: Gill Sans, 12pt, BOLD - I didn’t want bold!!! I never said bold. What the heck!!!

  • Title is now: Gill Sans, 28pt, Bold - I didn’t want 28pt!!! It’s defaulting to some built in format.

This is so, so, so Frustrating!!! Why, oh why, do some praise this software. I’m am about to give up on it.

Firstly, turn off the override function in [b]Project/Text Preferences[/b]. There is no need to set that up to precisely the same settings as what you have in the Formatting preference pane. The whole point of project text preferences is if you want different settings.

Secondly, I’m not sure what you are talking about with injecting “body” and “title” into the Formatting preferences pane. These are not words which have any relevance to the default formatting. You might instead be referring to a few of the sample Presets that have been provided to you as a demonstration of the Preset feature. They are just formatting macros. They have nothing to do with anything. You can call them “Chicken” and “Plaster” and they will perform identically to “Body” and “Title”.

So just forget Presets for now, or read up on them in §14.4.3 so you can discover what they are and most importantly, are not.

Just set your preferences up the way they look in the first screenshot. That’s all you need to do. I’m not sure what you are trying to do in the third screenshot, unless you want to write in a centre-aligned very bold and big font like that. If you want to, that is fine. I know lots of people who write in a very large font because it is easier on the eyes.

Anyway, I stopped using word processors because they frustrated me—mainly for all of the reasons you are going on about. I don’t want to have to bother with styles or formatting at all, I want to work in plain text. I’m plenty happy with a typewriter. Don’t frustrate yourself with software that doesn’t suit you. If you don’t find a fit with Scrivener, there are plenty of options out there.

Last piece of advice: preferences are more advanced than just using the program. If you want Scrivener to be dirt simple. Do the interactive tutorial, don’t touch a preference, and just use it. If you find all of this stuff overwhelming, just sit back, press the “Defaults” button at the bottom of the preferences window, and be content to work with how the program was designed to work out of the box. As you get more familiar, then you can start messing with stuff like this. You can make any program “too complicated” by trying to dive headfirst into the shallow end.

I’m sorry you’re finding it frustrating - I’ve dedicated the last seven years of my life to Scrivener, and to making it as intuitive as possible, but of course not all software will suit everyone. Compile can be a little complicated simply because it has to be flexible enough to allow for any structure in the binder.

That said, you seem to be asking about something different, and I’m not entirely sure what you are trying to do.

I think the first thing to point out - as I feel that this may be the source of confusion - is that Scrivener does have a “styles” system; it seems as though you are expecting presets to work like a styles system, but I may be wrong.

Next, there is absolutely no need to edit the “Text Preferences” in the Project menu unless you want to use a different format when writing in this project than in other projects. So, if you are just trying to set a default font and paragraph formatting for creating new documents in Scrivener for all projects, forget these settings (and deselect them).

I’m not quite sure why you have set it to use a bold, centred font in your screenshot; from your description, it sounds as though you have applied the “Title” preset to this formatting, but again, I’m not sure why you would want to do that. (The “Presets” are just a set of preset formatting that you can choose to apply to text anywhere in Scrivener. The text in the “Main Text Style” box is sample text that shows you the formatting that will will be used when you start typing in an empty document.)

Moving on to “Main Text Style” in the Preferences. This sets the default font and formatting that will be used in new projects.

So, all you need to do is ensure that the formatting in “Main Text Style” in the main preferences is as you want it for new documents - it’s as simple as that, so I think you are making things more complicated than they are.

Moving back to “Presets”. You can edit these and change them to be anything you want. (“Title” is set to be 28-point bold using the current font; “Body” is 12-point, left-aligned, using the current font. But you can edit them by typing some text in the format you want and going to Format > Formatting > Redefine Preset…")

Now, when you use Convert > Formatting to Default Text Style, all of the text in that document will be converted to use the formatting you have set in the “Main Text Style” of the Preferences. There is a warning that pops up telling you about this.

As for having a section title appear on the same line as the body text in Compile, click on “Level Settings” in the Formatting pane and tick “Insert title as run-in head” under the “Title Appearance” pane.

I hope this helps.

All the best,

First, thank you both for taking the time to provide detailed answers. Unfortunately, neither worked, though I have painstakingly try to follow your suggestions. So to make sure I understand you, here’s a brief list of my understandings and what I have done:

  1. No need to use the override function within the Project\Text Preferences if I have set the “Main Text Formatting” the way I need in the Preferences\Formatting panel. Got it.

  2. Presets are like Styles that can be applied at any time to text within the document. You can easily modify these presets by adjusting some text and then using that text as a basis to redefine the Preset. Got that too. Additionally, Presets are “brushed on” and don’t change dynamically. Sorry to hear that, but got that too.

Now, if my above understandings are correct, then it should work, right? Well here’s what I have done and it doesn’t.

a) Set the Preferences\Formatting back to Default (scroll graphic to right as needed)

b) Set the Project\Text Preferences to NOT Override (scroll graphic to right as needed)

c) Used the Project\Convert\Formatting to Default Text Style (scroll graphic to right as needed)

All that said, I still get Bold, when I don’t want bold and it’s not showing as bold in the Preferences\Formatting panel. See for yourself.

I’m really trying to get this program to work, but easy, I know you spent 7 years trying to make it so, but I wouldn’t say you’ve made it easy yet.

At any rate, I hope you point out something I’ve been missing.


Okay, the main problem you are facing at this point is that somewhere along the line (probably when trying to set the title font in the formatting pane) you ended up with bold everywhere. Main problem with that is: the default format converter is specifically coded to ignore things like bold (and italics, and highlights, and other “span-level” formatting) because in most scenarios you would not want to lose those things—you would want to reset the font and ruler settings to a uniform look and feel, but not want to lose every single italic, underlined, etc bit of text. In other words, this tool tries to be smart about it—but in this very specific case, that is working against you.

In your case, it would be easier to just select everything in the editor and press Cmd-B to remove the bold.

I’m somewhat saddened to see that after we’ve tried to help you, you have rather meanly gone and tried to damage our business by giving us a one-star review on the Mac App Store and denigrate us there without waiting for further assistance. This is a small business and we strive to make everything as straightforward as possible (whilst allowing for maximum flexibility) and to provide good customer service - I really think a one-star review based on the problems you are having (and the help you are receiving from two L&L people) is uncalled for, unfair, and, although I can understand the need to vent frustration, from where I’m sitting it seems unnecessarily malicious, whether intended that way or not.

But hey, moving on.

The problem here is that you used Convert > Formatting to Default Text Style when your formatting in the preferences or project text preferences was set to be bold. A warning will then have appeared:

You went ahead, at which point the text will have been converted to bold.

To reiterate: Convert > Formatting to Default Text Style will convert the text to use whatever is set in the “Main Text Style” box of the preferences. You had set it bold and so it got converted to bold.

The problem now - and admittedly this is an issue that this has brought to my attention - is that using Convert > Formatting to Default Text Style won’t convert the text back from bold. There’s a good reason for this: if you have lots of text and some of it is formatted to bold and some is italicised and so on, you wouldn’t want Convert > Formatting to Default Text Style to override that formatting and lose all your bold and italicised text, converting it to plain text. Thus the conversion maintains attributes such as bold and italic. The issue is therefore that Scrivener allows you to override it with bold formatting in the first place, which I admit has never come up before because it seems no one else has tried this, and I apologise that you have run into this unforeseen issue.

Ioa has provided you with the solution - now that you have your preferences set up correctly, load all your text into Scrivenings, select it all and just hit cmd-B to get rid of the bold. Now that you know how things work (and seeing as you were previously making things more complicated than they are), you shouldn’t run into this problem again, and I will look at the source issue of Convert > Formatting allowing you to convert everything to bold.

However, given that we have apparently “revelled in frustrating you”, I’m sure you’ll be returning to Word or Pages anyway, and won’t wish to continue using our “one-star” program.


Just in case anybody else somehow sets their default text preferences to use a bold font and doesn’t notice that they’ve done this before going to Convert > to Default Text Formatting, I have now added a warning that appears only if you have set the defaults to use bold (italic isn’t a problem because that just gets inverted and so can be converted back easily enough):

(The end of the warning tells you where the bold is set, either in Project > Text Preferences in the main Preferences.)

Ioa and Keith,

Thanks again for the speedy replies. The Select All, and CMD-B - worked. Simple enough.

Keith, I wasn’t trying to be mean. I was being honest. I have put more time into learning your program that any other word processor. I go back all the way to Wordstar v1, that’s about 30 years ago and all through the different iterations of Word. I think you have a powerful program, but the some parts of it are intuitive and some are, in my opinion as a consumer, not.

That can be cured in two ways. Make it more intuitive or explain it better. I have found your YouTube videos very helpful. May I suggest that this would make a great topic to make a video out of and also place prominently within your help PDF.

As another observation, there are some confusing parts of the program. Setting the “Main Text Style” apparently, as I have come to learn, has nothing to do with setting a Preset for the Body text. My thought in using many a word processor is that once you have specified some text as have a certain style (Preset) that once you change that style (Preset) the text should change. This is true in every other word processor that I know of, so Scrivener runs against what the user has come to expect. Therefore, I would recommend allowing the Presets (perhaps optionally) change the text dynamically within the document.

By the way, we develop software ourselves. So I can empathize with you. I will see about changing my review based upon your excellent support. That said, I think you might want to make this powerful and flexible program a bit easier to use or at least do more towards helping the user understand it.



I tried to revise my prior review, but it appears as though the App Store won’t let me. If you know of a way please advise me.

I also tried to create a new review, but that is not an option either within the App Store.

All that said, you still are showing 5 stars, so my little review has about zero effect on your sales.


Hi Don,

Unfortunately there is no way to modify reviews on the App Store, nor any way for developers to respond, sadly.

Anyway, I hope you’ll give Scrivener a bit more of a chance, but understand if you don’t.

All the best,

I don’t know if you can edit reviews, but you can delete them and resubmit. From the main window of the App Store, select Account (under Quick Links). You will prompted for your password. At the bottom of the Account Information page, under Settings is a line called Reviews and Ratings. To the right is a link titled Manage. Click on that and you can then delete individual reviews.

This person’s difficulty does bring up an issue that is worth thinking about.

Despite what seems to be the case, it is best NOT to consider Scrivener a word-processor. It is a drafting tool.

Consequently, it is best to begin using it just by using it, I’ve found, and then, bit by bit, altering it to suit. The point someone made about diving into the shallow end is exactly right. One thinks one grasps what Scrivener is about because one has used WordPerfect Word Mellel Nisus, WorldWriter and so on, but that is an illusion. Scrivener is for writing, not producing documents (those tangible things on paper). So beginners should begin by making the minimal number of adjustments so that Scrivener looks good on the screen, and then go forth! Effort should be directed at input skills and techniques—how to insert footnotes; what are annotations; how can I set up the screen so it suits my writing needs?

Then, and only then, should the writer dabble—as a distraction perhaps, as a time waster—in formatting output. This is backasswards to what one does with, say, Word. But after some frustration, I’ve decided this method gets one into Scrivener itself as opposed to the Procrustean exercise of trying to turn Scrivener into Word XIX.