Creating PDF output for Ingram Spark

Has anyone out there used Scrivener to create a Paperback Novel PDF suitable to send to Ingram Spark for on-demand printing? They have very strict margin specs and also require a PDF with certain characteristics.

Hi Dean,

Yes, I’ve been using Scrivener for my Ingram PDFs and am quite happy with the way the printed books turn out. You do need to follow their minimum margin requirements, but that’s no trouble to set up. I write long books (110-155k), so I like a bigger interior margin to avoid text falling into the gutter. For 6x9 I currently use: Top/Bottom: .75, Left: 1, Right: .5

One trick I use is to upload the PDF to Createspace just in order to use their interior reviewer (I keep one book over there in perpetual draft mode for this purpose). I like being able to see Createspace’s representation of a physical book, complete with gutter, so I can adjust the interior margin if I need to.

Also, I found the PDF works better if I compile to Print, then on the print options screen print to PDF.

Good luck!

Vanessa

Vanessa Kier
Power Up Your Writing Process with Scrivener- Now Open for Enrollment!
http://www.vanessakier.com/scrivener-course

Hi Vanessa,

Thanks for all the helpful detail!

Dean

I’ve noticed that the body text runs down so close to the Footer that descenders (p, j, g, q) touch the page numbers. This only happens on the occasional page, but it bothers me. I can’t find a place where I can set the bottom margin for the footer and then set a higher bottom margin for the body text. I tried playing around with the page padding for both Titles and Text but it didn’t make any difference at the bottom.

Thanks.

IngramSpark has a real issue dealing with ePUB3 output from Scrivener. It completely screws the text … I’ve had a battle going on for the last week trying to get this resolved. The iBooks side works well, but the Amazon side doesn’t. I recommend avoiding IngramSpark until they can resolve this!

Thanks Mike. I just use Ingram Spark for my print output and stick with Scrivener to create ePub and Mobi files, which I upload to stores on my own. I don’t get on as many stores that way, but I’m okay with that so far. My issue is with the format of the PDF file that Scrivener creates for printing. It’s a small thing (the tight spacing between the bottom of the text content and the top of the footer text) but I hope to tidy it up at some point.

Hi Dean,

This might be down to the printable area, which can be accessed via Page Setup. In the Compile Format editor, go to Page Settings. If “Use project page settings” is un-ticked, then you access Page Setup via the button there. If it’s ticked, then you use File > Page Setup… (For a project using custom page sizes, “Use project page settings” should not be ticked, though.)

In Page Setup, under “Paper Size”, go to “Manage Custom Sizes”. Here you will have to add a custom size and enter the page size you want. Under “Non-Printable Area”, you can set the values to 0 if they are not already. This might be the problem, if the footer is being pushed too far up into the text. Basically, Scrivener places the footer halfway down between the bottom of the text and the bottom of the printable area.

However, it only does this when printing. When using Compile to PDF, it does not take into consideration the page bounds so none of the above applies. I therefore recommend compiling directly to PDF rather than going through Print > PDF. If you’re still seeing the same issue, then could you possibly zip up and upload a sample project showing the problem, using the “Attachments” tab beneath the reply box?

Thanks and all the best,
Keith

Hi Keith,
Thanks for the detailed response. I have been compiling directly to PDF all along, so the problem must be something else than what you describe. I tried to attach a zipped copy of the project in question but it’s still too large. (I’m on a Mac, and the Mac zip function is not as good as I might like.) Here’s what I can tell you about the page setup and manage custom page size screens.

In page setup, my margins are set to what is required as page margins by Ingram-Spark. The bottom margin (where the problem occurs) is set to .6 inches.

In Manage custom size (I created a size of 5.25x8 inches for paperback books), the bottom non-printable area setting (user defined) is .5 inches. Perhaps the problem has to do with this discrepancy.

In any case, I need to be sure that my footer is not below the .6 inch margin required by Ingram-Spark. That is just fine as things stand. My problem is keeping the bottom of the text a little higher than it is now, without affecting the position of the footer. As is, only a very finicky reader is going to notice the few times that descenders in the bottom line of text touch the top of the footer. But it bugs me, so I’d love to find a fix if there is one.

I’ll try to get the zip tighter. I can also send screen captures of the compile screens and the problem in the PDF, if you think they would help.

Thanks,
Dean

Hi Dean,

You should just be able to create a copy of the project, delete most of the content from the copy, and add a few pages of sample or gobbledegook text, so that the project is small in file size but can generate a sample PDF. As I say, the non-printable area shouldn’t make a difference for PDF-only, so it’s hard to know what’s going on without seeing the project and experimenting.

Thanks!

Keith

Hi KB,

Here, finally, is a very reduced project. (It took me a while to discover the Trash folder, which I had to empty in order to make the project smaller). I compiled from this reduced version and it still creates the tight spacing between the bottom of the body text and the top of the footer. It’s most obvious on the first page of Chapter 2 (page 14 in the footer, page 16 in the PDF file.) I have also attached the PDF file that I just compiled.

Thanks very much for looking into this so deeply.

Dean
Finns-Clock-test-bottom-marg-footer.pdf (117 KB)
Finns-Clock-test-bottom-marg-footer.scriv.zip (299 KB)

Hi Dean,

Okay, I can see the issue there, and it is indeed down to the printable area. I didn’t realise you were on Scrivener 2 - what I said about the printable area not affecting PDF files only applies to Scrivener 3. (And the next update of Scrivener 3, 3.0.3, also allows users to control the header and footer position exactly, to avoid issues like this.)

You can fix this as follows:

  1. In Compile > “Page Settings”, click “Page Setup…”.

  2. Under “Paper Size”, choose “Other…”.

  3. Click “+” to add custom page settings.

  4. Set “Width” to 133.4mm and height to 203.2mm (or whatever you need).

  5. Set the non-printable area to 0 for top, left, right and bottom.

  6. Click “OK” and save everything, then Compile.

This should ensure that the headers and footers print in the middle of the margin.

All the best,
Keith

I’ve been lurking because I had similar problems with getting my top margins just the way I want them for Ingram Spark. When would you estimate 3.0.3 would be likely to ship? I’d like to judge whether I should go with the almost-correct-but-not-perfect margin, or wait to see if I can tweak it before uploading. (I won’t hold you to it. I write software as well as novels, so I know how delivery schedules for each can be exercises in dashed hopes.)

-Chuck
www.lampworkspublishing.com

Hi Chuck,

I’m already overdue - I had intended to release it a week and a half ago - so I’m hoping to submit to the App Store in the next few days and have it released next week. (I’m glad you won’t hold me to it, though, as I’ve been late before!)

All the best,
Keith

Hi Keith,
Sorry for the late reply - too many other chores this time of year.

Just a note of thanks for taking the time to work through to a solution. And it looks like I should upgrade, too.

Scrivener is a great product, which I’ve recommended to many people for its features. Now I know I can also recommend it for the quality of the support forum.

Be well,
Dean