CTRL + ALT keyboard shortcuts not working


Ctrl + alt keyboard shortcuts don’t seem to work in my version of scrivener. This is persistent across various scrivener files. Several of the default shortcuts include this combination (e.g. print preview, ctrl+alt+p), but I only get the typed letter. Other keyboard shortcuts work fine when involving either of those command keys, only in concert do the shortcuts not function.
Other programs are able to capture this key combination, so I’m pretty sure it’s either the application, or something with my settings.
Assigning new keyboard shortcuts with ctrl + alt show the same behavior (including another command key, like ctrl + shift + alt).
Can anyone reproduce this?

Thanks for your time,

Have you tried this with both sets of Ctrl/Alt keys (left and right)? Some keyboards (and Windows keyboard/helper software) use different scan codes so they can tell if you pressed left-Ctrl vs. right Ctrl., etc. They use this to offer various features – different keyboard modes for part of your keyboard (such as optimizing gaming, macros, etc.).

If you can swap keyboards, you might try booting into Safe Mode and using a plain alternate keyboard to see if that’s the case. If everything works as expected in Safe mode but not regular, you have some software or setting that is intercepting the key codes. If everything works on the plain keyboard but not your regular keyboard, there’s a keyboard firmware mode or setting in the driver/helper software that is intercepting it.

If none of that helps, I’d contact support.

Devin, thanks for the response.
I indeed tried with both ctrl keys, and as the scrivener keyboard shortcut assignment method picks up the ctrl + alt, but the editor doesn’t honor it, I don’t think that’s the issue. I’m using the default thinkpad keyboard, and have no issues with other programs using these shortcuts. There’s been no change to my setup, so unless I have some unique issue with my scrivener settings, this looks like a bug.

Is this not something you’re seeing on your end with ?

I tried Ctrl-Alt-P and sure enough, it inserts “P” in the editor. While Ctrl-Alt-P is not a defined shortcut, I think this violates the principal of least astonishment – if I hit a key + modifier I should not have the regular key result drop out.

The only Ctrl-Alt-* combo I found was Ctrl-Alt-Enter to open a document in the second editor. Print Preview is Ctrl-G, Ctrl-R (and it worked quite nicely).

Yes, that shortcut works for me also (ctrl + alt + enter). That’s the only one I’ve found.
Can you search for other default ctrl + alt shortcuts? “ctrl+alt” in the keyboard shortcut search in options -> keyboard will reveal these. (You probably know this, just including for thoroughness or others).
None of these shortcuts work for me, I don’t think I changed all of them, e.g. “Complete Current Title” ctrl+alt+4 types “4”.
Or you could set your own new shortcut with ctrl+alt+whatever, and then test it, I imagine you’ll get the same broken behavior.

Print preview must have been a shortcut I customized years ago and forgot about.
Definitely sounding more like a bug, but someone else reproducing a ctrl + alt shortcut not working would confirm it.

Really appreciate your help in determining if this is a bug!

Okay, I’ve never messed with my keyboard mappings either in Windows or Scrivener, so here’s the only Ctrl+Alt+* combos I see in my version (and no, I didn’t know about Options, Keyboard, since I tend not to tinker and customize too much as I move from machine to machine and not having settings follow me effortless just annoys me):

Ctrl+Alt+F3 Find Previous by Format
Ctrl+Alt+Return Open in Other Editor

That’s it. Those are the only ones bound to Ctrl+Alt+*. Even the one you mention, Ctrl+Alt+4, is not there (searched for bindings involving 4). In mine, it’s set to Ctrl+G, Ctrl+M.

So this may be a limitation of the Qt4 framework Scrivener uses, it may be a bug, I don’t know, but the default mappings seem to avoid using them.

Hmm, strange, I guess I customized them a while back. I use the option to load / save preferences quite a bit, so I’ve never had an issue customizing keyboard shortcuts before.

I’ll email support and see if they can take a look. I searched QT’s bug reports and didn’t see an active report for anything like this (closest was ctrl+alt+{numpad key} crashing some apps if pressed repeatedly).

Thanks for having a look!