Ctrl+V :: Changing function for Ctrl+V does not work. . . Can anyone confirm?

My default desire is for Ctrl+v to paste and match style. So, I remap the paste keys, reversing the functions.

Results: COPIED From spreadsheet: Using five vertical cells, one column.

Key commands: BOTH paste with original style
spread sheet cell outline and font

MENU: BOTH work as as expected with new mappings displayed.

Ctrl+v . . . paste and match style WRONG
spread sheet cell outline and font

Ctrl+shft+v . . . paste with ORIGINAL style CORRECT
spread sheet cell outline and font

MENU: The edit options display the changed key mappings

Edit: paste . . . (paste with ORIGINAL style) CORRECT
spread sheet cell outline and font

Edit: . . . paste and match style . . . CORRECT . . . No cell outlines, and default scriv font.

Have tried with two computers: beta 20 (64), Windows 10, latest build.

Confirmed this behavior. Remapping Ctrl+V to another command does not work.

There are several commonly-used commands that can’t be remapped / won’t stick. If there’s some fundamental reason for it, I think the program should not let me remap them.

That would be expected behavior, I agree. If Ctrl+V is not re-assignable, the program should not let me even try (e.g., warning message, “Ctrl+V is reserved”).

Ctrl+V must be re-assignable!
The first thing I do when install Scrivener is the swap Ctrl+V and Ctrl+Shift+V. Most of the times I want to Paste and Match the Style.
I hope they will fix that.

Is there a reason why we can’t reassign the Ctrl+V to Paste and Match the Style?

Because Qt catches and handles a lot of default shortcuts within the editor for us. Most likely there is a way to workaround this behavior but it is not straight forward and needs time to investigate and find a fix.

It works perfectly in 1.9. Can’t you copy the necessary code from there? :mrgreen: Please.


Different version of QT; the code is likely not compatible.

Given the difficulty, you might to invest a few minutes in making AutoHotKey or something similar swap the functions for now (thinking of this myself, as I use paste and match style more often than I use simple paste).

Still not working for me. Anyone?

This is still not working correctly

I have reversed the keymaps for paste. Crtl-v is set to match syle.

Ctrl-V pastes. It does not match style.

Edit ctrl-v does match style.

Workaround using AutoHotKey here: [url]https://forum.literatureandlatte.com/t/help-autohotkey-script-to-swap-ctrl-v-and-ctrl-shift-v/47182/6]

If you read the notes in that topic, you’ll see that this particular issue is a fairly deep bug. Don’t hold your breath, in other words; it may not be fixed for some time.

AHK is free.

How can a key mapping be a deep issue? That implies that changing any key mapping changes will not work.

Makes no sense to me. Prolly a hold-over from the mac stuff.

I’m not certain this is a bug within Scrivener or just something that has to be worked around from QT and Windows. FWIW, Windows 7 has this: Ctrl + Shift + V Move a note to a specific folder within the Windows Journal (not sure I ever used Windows Journal). That key combination is not used anywhere that I could find in Windows 10 or 8.1. That said, ALL of the Windows key combinations that are built-in by default are REALLY built-in - to the registry. It may not be possible (or desirable) to remap this particular key combination throughout Windows itself, just to satisfy its usage in one specific program. This is why there are a host of keyboard remapper utilities like AutoHotKey that might be the better way to handle this specific need.
If you are curious, here are the key mappings for Windows: support.microsoft.com/en-us/hel … -shortcuts

tiho said it was in the QT libraries they’re using. Thus, a bit more complicated. Normally, QT Keymappings are relatively easy to fix, change, et cetera. But Ctrl+V? Not so much.

Thus, the AHK script to fix it for those who need them swapped.

Ctrl+V Still not working.

I have change the key mapping so Ctrl+V is to PASTE AND MATCH STYLE.

Ctrl+V does NOT obey.

Right-clicking and choosing PASTE AND MATCH STYLE. Ctrl+V DOES works correctly.

Latest beta::: still not working

This will not be addressed at this stage as the Qt framework has Ctrl+V mapped internally for many more cases which we cannot control reliably. Switching it to anything else only in Scrivener, will cause all kind of different troubles.

This is why I said it was a deep issue.
However, all is not lost. As I mentioned earlier, Autohotkey can easily resolve the issue (autohotkey.com/). Free utility.

Once you have that installed, run this script:

#IfWinActive, ahk_exe scrivener.exe ^v::Send ^+v #IfWinActive, ahk_exe scrivener.exe ^+v::Send ^v
And your pastes should be swapped. I tested it on Windows 10; it worked fine.

If you prefer to have your pastes swapped, you’ll have to run it every time you start Scrivener, but that’s fairly simple.