Cursor Disappeared... bug?[NOTED]

Hi all,

I just downloaded the beta version yesterday and can’t wait to start using this software. It looks like a great tool :slight_smile:

I went over the tutorial project and afterwards tried importing one of my own pieces, but soon noticed that the cursor is not appearing anywhere in the main editor. It shows up in the index-card areas if I double-click there, or if I try changing a file’s/folder’s name, but not in the main editor…

Frankly, I cannot recall now if it was there to begin with (before I began fussing with the project), but I’ll try to list everything I’d done:

  1. First I tried importing my work (MS Word document) via the file->import option. I know that .doc and .docx extensions are not presently supported for import, but the prompt said they will automatically be converted into .rtf files, so I just assumed that it’s a faster way of doing the same thing (rather than opening the file in word first and saving a .rtf copy) The file showed up in the binder, but no text appeared in the editor, so I figured that my assumption was wrong.

  2. I then deleted the previously imported file, and instead copy-pasted the text directly from my MS Word document into the Scrivener Editor. At first I did a simple copy-paste and the text appeared with all the original MS Word formating (including italics, strike-through, embedded-links, etc) However, as I began breaking it down into smaller sections (via the ‘split with selection as title’ function) the formatting was lost and all the text was squeezed into a single long paragraph.

  3. Assuming this resulted from some incompatibilities between MS Word formatting and Scrivener’s editor, I again deleted the previous file and copy-pasted the text into a new one–this time using the ‘Paste and Match Style’ function. The text appeared fine (except for the lost formatting) and I was able to break it down into smaller segments without any problem.

It was at this point that I became aware of the missing cursor, though I believe it wasn’t there already following step #1 (perhaps even earlier, though I cannot say for sure).

I tried reopening the tutorial project to see if the cursor would show up there, but it didn’t…

Not sure if this might be a bug, or something I did wrong.

Any help would be greatly appreciated.


Maybe this will help: viewtopic.php?f=32&t=9157&start=0


I have had this too.
I did not really notice it like a kind of bug.
It happens mainly when I change the font to be used by the editor, before writing anything.
The cursor comes back when I just click on the indent slider.

But, yes, sometimes, there is no cursor on the first line, but well on the second one, even if empty.
And adding text to the first line works anyway.
Something weird indeed.

This is a logged bug. You can follow the link wolfman provided above to go to the existing thread about the bug.

Thanks for the help guys. I followed the provided link and ‘un-checking’ + ‘re-checking’ the ‘capitalize i’ feature under Auto Correct fixed it.

I do apologize for posting a known issue, but for some reason when I tired to search the forums for this problem the linked thread didn’t show up… :neutral_face:

I’ll be more diligent next time :wink:

Thanks again!

Did not have the disappearing cursor problem with 1.3, but I loaded 1.4 yesterday and when I clicked in the edit window, the cursor was gone. Searched the forum and found the “Capitalize ‘i’” fix and that worked. I’m running XP on a Dell Latitude.



Cursor did come back on my system after reinstalling Beta 1.4.

Alternate ‘cure’ for the invisible cursor problem:

if you go to Edit/Options/Editor and check the box for ‘block cursor’ the ‘normal’ thin line cursor appears.

Doing this just once seems to be enough – at least the cursor appears after exiting and re-entering the program.

OTOH, you don’t actually get a BLOCK cursor. And if you go back through options the box for block cursor is unchecked again, both during the same session when you re-enter the program subsequently.

Strange, but so long as I have a cursor mark, I’m good to go. :slight_smile: