Cursor disappears in composition mode

Posting this in “feedback” since everything I’ve posted in “bugs” lately has turned out to be intended behavior… :slight_smile:

So. I have a little thing that annoys me quite a deal. Using full screen (Okay, composition mode) with the paper color set to black, the mouse pointer tends to disappear when I move it. Sometimes it reappears when I stop moving it, sometimes not (but truth to be told, even if it does reappear it breaks my flow since I’ll be sitting looking for it, more often than not having lost track of it when I moved it).

Setting the page color back to something light, and text to black, this doesn’t seem to happen. So I’m guessing for some reason the cursor doesn’t retain its color if set to other than black, but keeps reverting to black thus turning invisible against my background.

(In fact, setting the paper to grey and the text to white, I see the cursor flicker between visible in black, visible in white, plus fully invisible. So not only does it revert to black, but if set to something else it also goes fully invisible in between.)

And yes, this time I’ve tried the whole re-start dance. :slight_smile: This happens all the time.
Bug? Or can we solve it? I’m on Lion, on a new MacBook Air 11".



Is it possible to take a screenshot to show what you mean? Is the cursor an I-bean (text insertion) or arrow when the problem occurs? Also, what version of OS X are you on?

The I-beam colour should use the text colour, although as this isn’t supported natively by OS X, I use a bit of a hack to colour it - after setting the colour, you may have to restart the project to see it working properly. But after that it should work consistently, so given that you’ve already tried a restart, that shouldn’t be it.

Thanks and all the best,

Screenshot… Well… I could, but either I would just send you a screenshot without a cursor, or one with… Don’t think it would help you much. :slight_smile:

Lion. 10.7.1.
MacBook Air. 2011 version, 1.6GHz i5 with 4GB.
Yes, it’s the I-beam I’m referring to.

It does sound like your hack doesn’t quite work for me, because again what happens is the cursor/i-beam keeps flickering/disappearing. If you set your paper to black and your text to white, are you getting different results? If so, what might be special with my setup?



Yes, if I set text to white and paper to black, the I-beam cursor remains white. If I click into the text view from another window, it returns briefly to the default colour, but as soon as I move it again it returns to being white (the text view essentially asks for its cursor whenever it moves, and in the ask-for-cursor code Scrivener applies a colour to the cursor). Mind you, with white-on-black, even the default grey cursor is quite visible - it doesn’t disappear entirely. So I still can’t reproduce this. Do you have WriteRoom installed? If so, can you see if that has the same problem for you (I believe we use the same code for the override)?

Regarding your set-up, no, nothing is different from those basics, really - I use a 2010 MacBook Air 11" with Lion, and a Mac Pro with Lion, both of which work fine in this regard.


Now that’s an interesting statement right there: “with white-on-black, even the default grey cursor is quite visible”.

Um, the default grey? If not selecting “Override text color with…” my I-beam defaults to black.

Have I been fiddling with some other setting?

(Thought I’d take a screenshot to show you, but apparently OSX hides the cursor before the shot anyway…)

ETA: Just to make it more exciting: I opened Scrivener on my semi-retired 2009 MacBookPro. There, the I-beam stays bright white no matter how much I dance around with it. Two-finger scrolling makes it turn grey (or in fact, it seems, one-pixel-wide white next to one-pixel-wide-black) but still stable and fully visible.
As far as I know, the only color-related settings I’ve done in Scrivener has been to mimic the settings of my MBP, with black paper+background and light text. Might it have something to do with the graphics card in the Air?

ETA again: Just tried to make a screen video, but the highest frame rate I seem to be able to set is 40fps which isn’t enough to see the flickering. Instead of disappearing completely, the cursor turns into an harder-to-see grey, and I’m guessing that’s the result of the flicker time being lower than the exposure time for each frame, making it look a solid gray when in fact it’s mostly black during the time of the exposure. If you see what I mean. I’ll keep experimenting though, is there anywhere I can send a screen capture?


You could send a screen capture to support AT literatureandlatte DOT com. Sorry for the late reply!

Thanks and all the best,

Just wanted to wake this thread up and say I just emailed you a screen capture.
To me, this problem persists in the new 2.2 (15858)


Just checking to see if you received my screen grab in the mail.

However, knowing it didn’t really show the problem’s full potential, I made another video filming my screen with my phone. I’m publishing it below. My problem is that with a dark background, the cursor disappears as soon as I start to move it. This leads to more of a problem than one might think — as soon as I go to somewhere else on the screen I will have to start looking for where I am, then adjusting the cursor, then look for it etc, until it finally ends up where I want it to be, and can click to insert it into the text.
(If I’m in a bright room, and the page is full of text, my eyes will end up searching for that cursor for several seconds every time I move it.)

Hope you can trace this one down. Also: I know this doesn’t happen on my MBP 13" early 2008, but it does on my MBA 11" late 2011. Same versions of Lion on both machines. Is this perhaps related to graphics card/drivers of my new Air?

Click here for the video




Unfortunately I don’t think there’s an awful lot I can do about this one. Although I haven’t seen the issue myself, it’s down to OS X to ask for the cursor, and when it does so Scrivener returns a cursor coloured correctly. There’s nowhere else to intercept this, so it’s down to OS X, I’m afraid.

All the best,

Just wanted to try and revive this topic once more — I keep having troubles with this one, and it stops me from using composition mode which is sad since it’s a great feature.

I downloaded WriteRoom to see if the issue was the same there, but it wasn’t. The cursor is as steady as can be, no flickering or disappearing. So if you do use the same code, there must be something outside of it causing my problems.

I’m guessing I’m the only one who has reported this. But (hey, everyone out there :slight_smile:) does that mean no one else is seeing it?

Any help appreciated.