Cursor formatting drives me insane!

One quirk of Scrivener that drives me insane all the time is that the font formatting at the cursor inherits whatever was the last formatting done on the text. For instance:

If I’m typing and finish a paragraph by inserting a superscript or a hyperlink, then hit enter to start a new paragraph, the cursor will still be set to superscript, or hyperlink, or whatever. The cursor will also inherit the indentation of the previous paragraph. How the heck do I set the cursor back to the default formatting???

I know about “documents/formatting/convert text to default text style” [Alt+x] but this reformats all the text on the page. All I want to do is revert the cursor at its current location back to the default text style. Surely there must be some easy way to do this, but heck if I know how.

This behavior also happens when pasting some text from the Internet. Whatever formatting is pasted now becomes the current formatting at the cursor. The only way I’ve found to overcome this, is to always keep several empty paragraphs beyond the cursor, so I can just arrow down to a default paragraph. But when typing on the fly, it’s hard to remember to keep the cursor from ending up at the end of your text stream.

What am I missing?

Ways I use:

  1. the paragraph icon to the left of the Font label: pulls down and offers a body option. This is your default body formatting.
  2. using Format > Formatting > Redefine and insert a & in front of body. This allows you to type Alt-r (format menu) r(formatting) a (apply) b (body) - To apply the body formatting to where your cursor is.
  3. The easiest is just to type the page and then go in afterwards and apply the formatting to what isn’t normal.

It would be nice though, if other formatting options acted liked bulleted lists where pressing an extra carriage return closes that special formatting and returns you to body formatting.