Cursor/text entry-/delete-point mismatch

Scrivener 2.2 has a bug that’s making the program unusable.

In the ‘scrivenings’ view, the current text entry/deletion point suddenly jumps away from, although within a few characters of, the cursor position. So, I place the cursor where I want it in the text (it stays there), look down to the keyboard to type, look up, and find that I’m deleting / adding text in a different place, a few characters away.

It happens despite opening/closing the program and rebooting. It doesn’t always happen while I’m typing but starts to happen more often than not after I’ve opened the program.

No other program exhibits this problem: it’s not the mouse.

Additionally, every time I type a character the entire scrivenings window twitches down by a mm or two.

I never saw this problem with Scrivener 2.1.

Nothing has changed in Scrivener 2.2 in this regard - no changes have been made to scrivenings or text entry. I can’t reproduce this and no one else has ever reported anything similar, either. Do you have any third-party tools installed, plugins that might interfere with or intercept typing? This sounds as though something else might be interfering. Could you post a video showing the issue?

No 3rd-party plugins. I routinely enter text into many programs on this machine and experience no problems with the others.

I now find that I can reproduce the problem only when I view and edit the entire book in one window – not when I view an individual text component (chapter).

I’m abroad and have no way of videoing the screen clearly but will send whatever I can by Monday when back in the UK.

Here is the bug(s) on video:
(I’ll take this down in the next day or two).

I have selected my whole book and am editing the entire text in the window (doesn’t seem to happen if I select a single chapter). I’ve added some dummy text near the beginning but it’s happened in the actual text at many points in the book.

Sorry the quality is not great but you can see: I start with the cursor placed immediately after ‘is’. At no point do I ever move the mouse or cursor. I simply type " fatally flawed " – with those spaces; I didn’t type two at the beginning although the cursor moves as though I did. Look where the cursor ends up - in the following word. This only happened after I’d tried something similar at various points in the para. I’m simply typing the letter ‘b’ repeatedly. Look at the words ‘remaining essentially’ 3 lines above. Despite the overall camera movement, you can see that the (whole) line jumps noticeably every time I type. This jitter happens mostly but not always.

BTW, can I downgrade to 2.1 so I can get on with my book?!


Downgrading to 2.1 will have no effect - nothing has changed in this regard.

The “text jitter” is normal - it’s because you are using a scaled view (you have set the text to something above 100%) and the OS X text system often readjusts itself as you type in a scaled view. It’s not ideal, but this is out of my hands, unfortunately, as it’s Apple code. It only happens when the text is at something other than 100% zoom. Turning off “Fine kerning” in the Editor preferences might help.

The cursor jump is bizarre; I’ve never seen anything like it. Could you please go to ~/Library/Application Support/Scrivener/Logs (you can access the ~/Library folder by holding down the Option key when opening the “Go” menu in the Finder) and open Console.log in a plain text editor the next time this happens? If there is anything in there, please copy the contents into your reply.

What scale is the text? If you change it back to 100%, does the cursor jump problem disappear too?

2.1 can be downloaded from this page: I’m almost certain it will make no difference, though, and that the update just coincided with these issues occurring for you.

All the best,

Thanks for the reply. I’ve answered your specific points below but the biggest new fact is that both problems go away when I load exactly the same .scriv file with Scrivener 2.2 on another Mac. The other Mac is 10.6.8. The Mac that exhibits the problem is 10.5.8.

A search for (mac os x cursor misalignment) comes up with similar issues pertaining to other programs. Maybe this is an OS X bug.

In response to your points:

Scale was 125% (and was before this problem began). I changed it to 100%. Same jitter. Dropped the ‘fine kerning’ preference. Same jitter.

The console.log file was empty before and after I reproduced the cursor misalignment problem.

BTW, I had the font size set high (36pt) so you could see the effect on the video, but the same happens when it’s 12pt.

Also I verified that neither problem occurs if I look at that text in the chapter file instead of the whole book.

The cursor jump bug is suggestive of a different font specification being used, sometimes, for cursor positioning than for display. I remember doing a global font-setting operation not long ago, i.e. from within the whole-book view, because I had different fonts in different chapters. It’s possible that the problems started after that point rather than when I upgraded to 2.2.



I recently changed to 2.2 and seem to have a similar problem in compose mode. I get the same ‘jiggle’ (my zoom is on 150%) and I find the cursor jumps around on occasion as if there was something wrong with the typewriter scrolling.

For example, I’ll be working away with the cursor half-way down the page, then perhaps highlight a word and delete it and the cursor will jump down to near the bottom of the page (roughly the 3/4 mark).

I’ve been trying to analyze the types of thing I do to trigger this, but it’s difficult. For a while I wondered if it was just me, but then I saw this post.

Steven - that’s a different issue, pertaining to a bug in typewriter scrolling (that has been present in all versions of 2.0) that I hope I’ve fixed for the next update (after Christmas).

Tim - thanks again for the extra information. If there’s nothing in Console.log, that indicates that there’s no error getting thrown at least, and if it is only happening on 10.5.8 then it is possible that it’s a text system bug that Apple have since fixed. The text system does tend to have more display issues the more a view is scaled - I’m surprised the jitter happened at 100%, though. All text drawing (other than things like inline annotation bubbles) is handled by OS X, though, so I do suspect this is an OS X bug. Are the preferences pretty much the same on both machines too?

Thanks and all the best,