Custom icons in binder not working

Until the most recent update, I was able to add custom icons in the binder to any or all of my projects, so I know how to add them. However, since the update, it’s simply not letting me change the icon to a custom icon I’ve uploaded. It’s letting me change the icons to any that are pre-installed, but it isn’t changing the icon to the ones I’ve uploaded. It worked okay in the NaNoWriMo file, but it’s not working in the rest. I’m using Scrivener for Windows Version:

If it is only custom icons you’ve added that aren’t working properly, I would suspect there may be a problem with the file format used for the icon, or maybe just the file itself. Have you tried with a few others that you know work, from other projects? (For example, in your NaNo project, you should find the ones you installed in its Icons subfolder, and you could even just copy those files directly into the other project’s Icons folder.)

1 Like

Thank you. I copied the files over from the NaNo project and those custom icons are all working fine. The icon I’m uploading is the exact same format. It was a .png and I thought perhaps that was it, but the others are .pngs too. But I created a .jpg of the custom icon and uploaded that, but it still listed it as a .png. I tried to change the icon to one of the ones I copied over, and that worked. So then I tried to change the icon to the new uploaded .jpg that still turned into a .png, and it bounced back to the default icon.

Here are the images I’m trying to use:

The Ace of Wands works, but the Fool doesn’t. Both are .pngs. The Fool is only a bit larger than the Ace of Wands.

You mention that they are both PNG files, but what I downloaded from here are two JPG files. I don’t know if that’s the forum software converting the images though, this probably isn’t the best medium for checking whether an image is properly formatted or not. You could try zipping the originals and uploading the .zip, that way it won’t potentially mess with them.

My guess though is that the file extension is wrong, so the software is getting confused about what kind of file it is.

I’d also note these are rather massive for what will only ever be displayed as a 32 x 32 pixel graphic. I don’t think that will mess anything up in particular, but it’s a lot of “wasted” space for details you’ll never see.

1 Like

Okay, I created a new jpg of the fool and made it tiny. That reduced it to 165kb, which is a third of the size of the original one. It still uploaded it to Scrivener as a .png, but it’s worked this time as a custom icon. Perhaps it was just too big?

Thanks for your help. Could the .jpg changing itself to a .png be a bug? Could it simply be mistaken and displaying it as a .png? I’m definitely saving it as a .jpg and the other one is definitely a .png.

As a bit of a PS… this Fool custom icon was also in the NaNo file, but when I copied the folders over to the original file, it was the only one that bounced back to the default. The Fool icon was still there, in manage icons, and it still worked in the NaNo file. But I couldn’t get it to work in the non-NaNo file.

The “Manage Custom Icons” tool will convert the image and downsize it for you, so that’s why you end up with PNG files when adding JPG files to it. I’m not really sure why it wasn’t working before though! I tried both methods using the images you provided, and both sets of icons worked fine—but again the forum may have converted them or something:

Honestly I never use that tool, and just add things to the Icons folder directly—mainly because I don’t like how it converts the file and changes the size (I think it also destroys any transparency). But I’m pretty picky, to the point of designing my custom icons down to the pixel. :slight_smile: I don’t want anything screwing with the pixels automatically!

1 Like

I thought that was the only way. I couldn’t get my screen to look like the one on the blog, and thought it was a difference between Mac and Windows.

This is what I don’t see:

And here is my binder with two other icons that worked in the NaNo file but not this one:

(The Ace of Swords and the Ace of Pentacles)

Where do I find the icons folder? It won’t let me do a screenshot of my change icon menu, but it looks like this when I go into manage icons:

If there’s an easier, quicker way that works, I’m all for that! :smiley:

For info, here’s what the NaNo binder looks like with the icons working:

They’re the same files and I’ve uploaded them in the same manner, but they didn’t all copy across.

Yeah, the developers still need to add the ability to install global icons that all of your projects can use, rather than project-specific icons alone. That is why the Mac screenshot has two areas.

Where do I find the icons folder? It won’t let me do a screenshot of my change icon menu, but it looks like this when I go into manage icons:

It is on the disk, located in the subfolder for your main project. So to use one of the screenshots here, it would be an “Icons” folder inside “The Fool STC.scriv”, located alongside the Settings, Files and other folders, as well as the .scrivx file you’d double-click on to load the project.

So I’d be curious to see if you went into the NaNo project’s folder and, using File Explorer not Scrivener, copied those icon files directly into the other project’s Icons folder, removing whatever is there at the moment, first.

P.S. I used the tarot as a structural device for one of my NaNos, many years ago. It was a fun experiment!

1 Like

Ah, okay. I’ll have a look, but won’t be able to this afternoon now. Is it okay to come back in a day or so? (I do ‘my’ work in the mornings and client work in the afternoons, so I’m on client time now. :blush:)

I found the icons folder in the NaNo directory and copied them across to the icons folder in the non-NaNo directory and that seems to have worked. Thank you. I still think there might be a bug in the change icon/manage icons menus, though.

There may well be, if you get a chance to .zip up the original images you were trying to add via the Manage panel that weren’t working (and maybe one or two that do, for comparison), I could take a better look at it.

1 Like

This is the .jpg image it wouldn’t let me upload to the non-NaNo project, but it did let me upload it to the NaNo project. Well, it let me upload it to both, it just wouldn’t change the icon in the non-NaNo project.

0 the (448.2 KB)

It’s saying the .png is too big to upload here, and the ace of wands & cups were both .pngs and they worked in both files.

I do think that there are other differences between the NaNo file, which came with a special download, and the non-NaNo file, which came following a dictionary fix to the latest update. The NaNo file works so much better than the non-NaNo file.

Strange, the original file still works fine for me, and I am using the same version you are. Well, at least we have things working with the new project for now.

1 Like

Perhaps some sort of corruption has crept in… But yes, thank you. I have my nice, sparkly icons working again. :smiley: Perhaps it’s something in the template I created…

Another day! Another topic.

1 Like