Custom metadata columns lose text wrap and column position in outliner

One thing I’ve noticed… I wish the character and setting columns let you stack the names vertically… they only write out horizontally, causing the column to get even wider, and then I have to use the slider bar more often.

Also, when I closed the project and then went back into it later, it rearranged all the columns and changed the widths of them. I had to readjust them in the order I like and widen some of the columns.

Turn on the Wrap Text option in the dialog for creating custom metadata:

Does that help?


Each editor (left vs. right) is supposed to remember its own Outliner settings.

If, for example, you set up Outliner columns just the way you like them in the left editor, and then in a later session you opened the Outliner in the right editor, the right’s columns would be different than how you had set the left’s.

Any chances something like that is going on?


1 Like

I clicked wrap-- thanks for the suggestion! But it didn’t work. I’m using Windows version. I tried closing the project and coming back into it, but still no wrap. And columns were rearranged again.

1 Like

Just to be sure, I brought Outliner up in both editors, set them the way I like them, then closed the project and came back into it. Both were still rearranged. Hmmmm… I’m using Windows version. Don’t know if that’s making a difference.

@washbear, I can confirm what you’re seeing.

Custom metadata text seems to wrap in the column when it’s first entered, but on subsequent sessions it doesn’t wrap.

Also, the Outliner does not remember column positioning between sessions.

These are bugs.

I’ll submit a ticket to L&L support.



Thank you! You’ve been very helpful!

Sorry to hear of the bug. :pensive:

I’ve been trying to reproduce the issue of the columns shifting and the text field not wrapping properly, but so far I haven’t been quite successful. I did find a bug of the custom columns shifting after adding new custom metadata fields in Project Settings, but that didn’t affect the wrapped text display, and it seems not to be the same as described here, where just closing and reopening the project is adjusting the outliner display.

Are you able to reproduce this in a new blank project? Do you see any difference depending on the number of items in the outliner or the width of the editor, such that horizontal or vertical scrollbars are visible? For the text wrapping, is the setting actually disabled (i.e. if you view Project Settings after reopening the project, is the “Wrap text” checkbox no longer clicked) or is it just not drawing properly in the outliner column, but in the inspector metadata, for instance, it appears correct? Does adjusting the width of the editor slightly or any of the columns’ width cause it to correct itself?

Hi Jennifer @MimeticMouton ,

Thanks for looking into this. :grinning:

I haven’t investigated the wrapping issue further, but I am easily able to recreate the shifting columns problem.

Here are the steps:

  1. Create a new project using Blank template.
  2. Add a new text custom metadata column from Project Settings
  3. In the Outliner, enable display of the new column and move it to the second position on the left, just after Title and Synopsis
  4. Close & reopen Scrivener
  5. The new column has shifted to the rightmost position

I tried moving the custom metadata field to other column positions, but no matter where it goes, closing and reopening the project moves the custom metadata field all the way over to the rightmost column.

Are you able to recreate using these steps?


Aha! Thank you for the screenshot; that provided the missing clue. I’m not able to reproduce the problem in the default theme, but switching to a different one does cause the columns to shift exactly as described. How bizarre!

1 Like

Yes, that is bizarre. Never would I have imagined theme choice would play a role in this. :man_shrugging:

Part of the prefs file in the Theme, maybe?