Custom paper size?

Hello,

Newbie here.

Where/how do I change the page/paper size in Scrivener?

File > Page Setup > Paper Size just shows some standard sizes. I want my print-ready pdf to be in a specific size? How do I set this up?

Well in my version of Scrivener, the bottom option in the Size drop down list is called “User-Defined”.

But… How the users defines the Paper Size is Undefined. Choosing the option, nothing happens. And it’s not even in the User Manual Chapter 26 Printing.

When I actually choose Print Current Document… a Print dialog window appears and using the Preferences button I found the Documentt Size list box with the very same options as in Scrivener. Selecting User Defined there at the bottom of the list, I actually get a dialog box allowing me to enter Paper Width and Paper Height in mm or inches:

image

But this may vary for your printer.

Another option is to print via Compile for Print.
There is a Page Settings tab in the windows that opens when you double-click your Format in the Compile Overview Screen. On the right is a Page Setup… button. That allows choosing several default papers sizes AND has a Custom option a the bottom of the Paper Size listbox. Clicking the Ellipsis […] button next to the box reveals another dialog box, containing an option to enter a Custom Paper Size and Margins. Yeah!

image

Success!

How is it done in Scrivener 3? I dont get why there’s no straight forward to accomplish this

Didn’t I just tell you? :slightly_smiling_face: This Is Scrivener 3. You may have a different printer. Compiling for Print works always.

It is straightforward, at the Paper Size dropdown.

On a mac, yes. On Windows it’s different. :wink:

On Windows, it’s a couple millimeters from the same location. Click Custom, then ....

It doesn’t depend on printer settings or even if you own one.

thanks! But how did you open this popup window again?

Ok i got it finally! Thanks a lot for the help! :slight_smile:

Paper size → Custom → ...

For the sake of anyone else who might be facing this problem, here’s how to reach the Custom paper size setting:

File > Compile > Click “+”> New Format > Page Settings > Uncheck "use project page settings > Uncheck “use default paper size” > Paper Size

But doing the above does not apply on the “Page View”.

Appreciate if anyone can share how to change the page size for “Page View”.

Thanks

Thank you for your help, but it doesn’t work. Maybe I wasn’t clear in my question. Let me try again:

When I go to View File > Text Editing > Page View… it shows a generic A4 size page view. How can I change the size of this page view?

Please let me know if its not clear. I can record a video to explain further.

Thanks!

I actually found the answer to this by digging around into the software.

These steps apply if you want to change the size of the “Page View”.

Here are the steps:

File > Print Current Document > Preferences > Paper Quality > Custom > New

Give it a name and enter the custom size. Then cancel everything.

Then go to File > File Setup > Paper Size… there you will see your custom size in the drop down menu.

You’re welcome :slight_smile:

Sorry that’s File > Page Setup…