Customizing colours for "Assign Section Layouts" window

When I’m in the Appearance tab of the Options menu, where do I adjust the highlighted selection when under the Assign Section Layouts menu or the Compile menu? (See screenshot below for the compile section I’m referring to.)

There is almost zero difference between selected and non-selected, so it’s effectively not “highlighted” at all. I’d like it to be more than a half-shade different, so I can actually see what I’m selecting. :wink:

Interesting question. I always thought even in the default Theme the difference was insignificant. In these Themes the contrast is even less.

Well, you can unzip the scrtheme file and adjust the color palette. For now, it’s a guess what color to change and what the consequences of that change are.

I’ll investigate in my Primary Colors Theme and let you know…

1 Like

Hmm… I don’t think I can (or should) do that. :wink:
The screenshot on top is the Solarized Light theme, which is the one I use. I tried switching to a darker theme to see if it helped, but as you can see, it didn’t do much.
I went through every Color tab in the Appearance menu and couldn’t find anything that seems to apply.

Obviously, the color we talk about is the Yellow called Highlight.

When I change Highlight to Red, it shows. Not only there, but also in the menus, the active button and many other places. The selected Binder item stays warm gray.

So, I dragged a slider in Photoshop, and came up with this Highlight color.

With the Theme come at lot of other preferences, which may not by your choice. You could save your prefs using File > Options > Manage > Save options to File… and apply them back after installing this Theme: File > Options > Manage > Load options from File…

Here is your personalized SolarizedLight Theme, called SolarizedHighlight :slight_smile: (18.3 KB)

Unzip it to a scrtheme file and choose Window > Themes > Load Theme from file… If you like it, you could Window > Themes > Import Themes…

Hope this Helps…

(I should go and start writing again…)


Wow! That’s perfect. And much appreciated.
Thank you!

1 Like

OMG!!! Does it mean that I can change the toolbar color too in photoshop? I mean, customizing is great, but I just really love the default appearance of the toolbar and the white in the windows… How exactly can I do that? Or maybe it’ll be fixed if the default appearance would be actually a theme, you know, a file .scheme, but how?

Sorry if my English is not very good, It isn’t my native language.

Yes, but not in Photoshop. You have to create a Theme. The. scrtheme file is a Zip file you can unpack to a palette, stylesheet, preferences and an XML-manifest…

1 Like

Thanks for that! I already have the zip file and unpacked it. Now, do I have to change every one of the files, or just some of them?

Any text Editor opens each of the four files. The palette is annotated, so you might discover yourself how to change the colors for the toolbar. If you can’t find it, I will investigate and determine it for you.
Zip the four files with a dedicated zip tool and rename the result to .scrtheme. Load it from file from the Window > Themes menu. Restart Scrivener to show the results.

1 Like

I did it! You are a Masterrrrrrrr!!! I’d hugh you if you were in front of me. Thanks so much!!!

1 Like

I dit it, I swear but I don’t know why I can’t use it. Scrivener keeps saying “Cannot find the theme configuration file” :pensive:

Seems like the XML manifest is missing, wrong or corrupted. Check your Theme for wrong names in the XML-file. The Theme filename should be the same as the name mentioned in de XML-file.
Also check the exact names of the other files.
If nothing works, copy the XML-file from the original Theme and rename the Theme if necessary.

Ok. Finally I did it. This is what I was doing wrong: The extension scrtheme doesn’t work for me. Just the pure name of the theme which in my case is “White” without any extension. That was it, haha. Thanks, AntoniDol for your help. As soon as I finish retouching my white theme I’ll share it so no one else has to suffer like this. Thanks a lot!!!

1 Like

Here it is the Default theme finally, which I named White Theme. Enjoy it: (34.3 KB)

Please, just change de extension from .zip to .scrtheme
Or, leave just the name without any extension. This way is the one that works for me.

Ola Pao,
I’ve added a link to your post with images to the Windows Themes post.

1 Like

Antoni, downloaded your solarized highlight theme, did not realize and all my language settings are changed from english. Tried loading old themes and preferences to no avail. Any help to get back to english would be great.

Language settings are at Options > Corrections > Spelling > Dictionary.

Save your Options to File via the Manage button in the Options Dialog.

Thanks will do when home. Otherwise scrivener becomes much more challenging.