Cut and Paste from ChatGPT

Hi I am using ChatGPT to research a project. I’m frequently cutting and pasting (using the provided button in the interface) answers into the research folder in Scrivener so I can link to them from a timeline I’m creating. The cut and pasted text converts the bolded headings in the ChatGPT answer to plain text with hashtags. I’m wondering if there’s a way I can get the text to look the same as it does in the ChatGPT window. Thanks!

Use Paste and Match Style in Scrivener, instead of Paste.
It will make your text in Scrivener look consistent and drop the junk pulled in with the content you find useful from ChatGPT.
Being on Mac you also have a Zap Gremlins feature, though being a Windows user, I have no idea what it actually zaps, but others have recommended it.

What’s happening is that ChatGPT’s response is formatted with Markdown. Their interface apparently has a Markdown rendering engine, but the underlying data is just text.


Thanks for this. Yes it does look like Markdown formatting. I did try paste and match style but no difference. Is there some way of stripping out the Markdown or better still using it to format the text in the Scrivener doc?

Refer me to a piece you copied and used Paste and Match Style to paste. I’ve never had the experience of it bringing over a mess to my documents.
Tools like Grammarly on the other hand will mess with your smart quotes and the like, but that’s easily fixed with a keystroke combination.
Did you Zap Gremlins?

Hi thanks very much for the help. Here’s a cut and paste from Scriv of the copy-paste and match style from ChatGPT. I did try zap gremlins (highlighted the text after pasting then selected zap, is that correct?)

Winter 1941-1942:

  • Positioning: During the winter of 1941-1942, the LSSAH was part of the German forces engaged on the Eastern Front, specifically within Army Group South’s area of operations. This area included southern Ukraine and the Crimean Peninsula.

  • Operations: The division was involved in defensive operations to hold the German front lines against Soviet winter offensives. The harsh winter conditions and the determined Soviet attacks created significant challenges for all German units, including the LSSAH.

oops, the forum read the markdown perfectly! :joy: in Scriv it was markdown with the hashmarks etc

may well be something very basic I don’t know - I’m not at all savvy about Markdown, I just know what it is and some of the formatting symbols, that’s about it

Sorry, can’t say. We don’t have the feature on Windows.
I’ll lookup the reference on ChatGPT when home and see what happens on my side.
I take it your documents have a common formatting you’ve pre-set? There’s also a menu option to apply default formatting throughout a document, probably under Documents.

One thing is that if I just select the text, then copy and paste, it comes out properly formatted. I only get this issue if I use the “copy” button at the bottom of the GPT reply. So I guess I’ll just manually select and copy from now on. thanks for the help!

Scrivener can’t control what other applications put in the clipboard. Apparently ChatGPT and your browser disagree about what a “copy” should look like.

1 Like

That sounds about right

It’s a pity that in this year not more applications support at least basic markdown.