Cycle through windows shortcut?

Assuming there is no shortcut for this, it would be nice to have! I’ve got several Scapple windows open and moving between them could be easier.

You don’t specify your OS/platform, but under windows, that’d be a windows’ shortcut.

Yes, that’s really a window management question, and thus very much depends on the operating system/window manager. In many Linux environments it will probably be Alt+` and similarly on macOS, ⌘` (and that may also change depending on keyboard layout). Some systems also have a more visual way of handling that, too. In KDE and macOS I can press a key that fits all open windows from one application down to the screen size, and I can click on the one I want by sight. I don’t think Windows has anything along those lines though, at least not without a separate install.

Thanks for your help. I’m on Mac. I tried the command + ` shortcut and it worked exactly once. It cycled through all the Scapple windows I had open and when it came to the last one it stopped and I’ll be damned if I can get it to do it again. After quitting and reopening the program, again it cycles through them once and stops. Any idea what is going on?

Likely there is a shortcut to go the other way (?)

In the keyboard shortcuts of system preferences/settings, double-check that Move focus to next window is enabled and has the desired shortcut assigned. With the ⌘` shortcut, you can to add the Shift key to make it cycle in the reverse direction, but it should normally be cycling, not reaching the last window and stopping. Do you have any other software running that might be conflicting with it as a global shortcut or doing some sort of other window management? From the system preferences pane, you could try changing to a different shortcut. Does the same one-time-only behaviour happen with multiple windows in other apps?

Thank you. The windows of all the other apps I tried (Iterm2, firefox, safari) continue to cycle through as expected. It seems to be only this app. Adding the shift does allow me to go backwards, so at least that helps.

For some reason I am having trouble adding any app shortcuts in settings so maybe this is a problem with my machine. I will investigate more when I have time.