Dark Mode disregards my Composition Mode background

When I switch to Appearance/Dark Mode in Scrivener, it seems to disregard my Background selection for Composition Mode. Instead of showing the background, it shows whatever’s behind the program (desktop, web browser, etc.) with a slight opacity setting.

Dark/System Default Setting:


Light (also dark) setting:

Are there two separate backgrounds for each mode in Preferences, or is this a bug?

Dark and Light mode each have their own themes, basically, which are stored in your preferences. When in Dark Mode you can switch between themes without impacting the appearance of Light Mode appearance settings, and vice versa.

If you would like for both modes to have the same composition mode appearance, what you can do is first change to the mode you want to copy from, then use the Manage… button in Preferences to save a Theme. In the dialogue box where you name it, you can set what types of things the theme will change. Set it up to only modify Composition Mode settings.

As you may know, Themes usually change your appearance mode, but font-only and composition-only themes will not. So switch the overall Appearance of Scrivener to the other mode, and use the same button to apply this theme. Now they should both have the same Composition settings!