decimal points

I’m using Scrivener to write a paper that at various points must, in the text, refer to decimals. I’m finding that Scrivener does not appear to recognize numbers containing decimal points as a single unit of text – as a word, really – so that, for example, if .009 appears at the end of a line, it may appear as . on one line and 009 on the next. In other words, Scrivener treats the decimal like a period.

Will this persist after I’ve compiled to RTF, and if so, what should I do? Thanks.

I’m not sure if this would help, but you could try to deselect in
Scrivener Preferences -> Auto Correction -> Fix capitalization of sentences.

From the Nisus Writer Pro forum:

[code]We have a solution, as the zero-width non-breaking space is part of Unicode (as U+2060) and Apple’s typesetter handles it just fine. Here’s what to do:

  1. Place the caret after the “:” character.
  2. Type the text “U+2060”.
  3. Select exactly the text “U+2060”. Be sure not to include any surrounding characters.
  4. Use the menu Edit > Convert > From Unicode Code Points.

You should now have a non-breaking space following the colon. If you use this a lot, it might be a good idea to add it to your QuickFix expansions. You can also use the menu Edit > Special Characters to insert non-breaking spaces, but it can be somewhat involved.[/code]

That’s in NWP. I imagine that in Scrivener, if you choose and set up the pane to show Unicode, you can scroll down to 2060, and although nothing shows in the first column, if you click there you get a grey box and the description on the right says “WORD JOINER”. You should be able to insert that after your decimal point, and I think that should do the trick … I’ve not tried it myself.

And you could presumably set up a key combination for it in your Text substitutions in System Preferences, or in Text Expander/Typinator or one of those.

Mark

Thanks for both replies. I’ve already got my auto-correct capitalization turned off.

Mark, your suggestion sounds promising even though I didn’t quite follow it all. I’ll play around with this and report back if I can get it to work. Thanks again.

Here’s an image with comments of how to get at the “Word joiner” on the Character Viewer.

To access the Character Viewer, you will need to tick the “Show Input menu in menu bar” option on the “Input Sources” pane of the “Language & Text” preference in the System Preferences if you haven’t got that set up already. I think it’s worth doing even if you only use one language setting.

When you’ve done that, do as shown in the image below.

HTH

Mark

Actually Scrivener has a quicker way to insert the word joiner character:

Edit > Insert > Word Joiner

(You could therefore set up a keyboard shortcut for “Word Joiner” in the System Preferences if you need to add it a lot.)

This does exactly the same as Mark’s suggestion of using the character viewer, but is just a shortcut, really.

All the best,
Keith

You can tell how much I go through the menus to look for things! :blush:

Mark