Default Style and Other Newbie Questions

Paragraph indenting in the Editor works pretty much like Word (and most all word processor software nowadays and for a long time), so if you go back, you’ll be doing it the same way.

You don’t give any details on your setup. But …

  • turn on the invisibles so you can see what’s a paragraph, where the tab characters are, etc.
  • also turn on Ruler which (you have done, you say)
  • put cursor in the paragraph that troubles you
  • Menu → Format → Paragraph → Tabs and Indents … → See the settings there for your paragraph indent, tabs, etc. Change to what you want.
  • if you want that default Menu Scrivener → Preferences → Tab Editing → click on “Use formatting in current editor”

Without looking for specific references, I’m quite sure all this discussed in the Scrivener Manual. Probably section 15.7

You mentioned Styles … if you are planning to use them, use only by exception–otherwise use “No Style” most everywhere. Styles also explained in the Scrivener Manual (and much past discussion here).

1 Like

thank you rms for your ever so prompt answer. I had done everything you suggested except the last bit - i could not find Menu Scrivener → Preferences but in looking for this i tried File → options → editing → formatting somehow in my travels i had seen something like this screen before but it was not editable (if that is a word) I have altered things here and will try to set this as an overall default.
Anyway i THINK i have finally altered that pesky indent. Thank you again.

Probably worth your time to go through the Scrivener Tutorial again.

1 Like

other item i did was the Style “no style” kept appearing. i had changed to my style and then selected Format → make formatting default but “no style” kept appearing. so i typed away in “no style” got the text and indents how i wanted them then selected Format → make formatting default somehow that has helped too probably not the best way to do it but its working at the moment.

just saw your pic i dont seem to have that scrivner option
think you are right back to the tutorial :slight_smile:

Well, why the Scrivener Menu is not there is a big mystery. I’ll let you work on that as I have no idea why not.

Just remember that Scrivener is NOT really the WYSIWYG Microsoft Word default concept. The editor is not intended to be a formatting tool. All that gets done by the Compiler.

Scrivener is a writer’s tool, not a “word processor”.

1 Like

As you have the Windows version, it is File - Options - editing and then the format tab.

2 Likes

I’ve merged this with a very similar thread, which already goes over all of this.

As for setting default formatting, as noted above, it is most often a lot easier to use the one single menu command necessary to set defaults, than to drill down into options.

I am trying to achiever something very, very simple, but failing. Whenever I add a new file to a folder, I want the formatting of the text to be a particular font, a particular size, spacing to be zero before and after paragraph, and line spacing to be single. Initially, I created a block of text, applied this formatting to it, and then saved it as a template. I then opened a new project based on that template, but, whenever I add text to a new file, different formatting (particularly “Before paragraph: 0”, “After paragraph: 8”, and “Line Spacing: Multiple”.) is applied. What do I need to do to achieve this very simple requirement, please?

Yes, I do think this is quite a bit more simple than you’ve made it! I’ve merged this into a thread that discusses how to adjust default formatting, which is really more the term you are looking for I think, rather than using templates. Using document templates to adjust default formatting is a possibility, but it’s inefficient given the software actually has features for changing the default formatting in its settings (both globally and optionally for each project). And of course if this is a project-specific preference, you could then make your project template with the settings saved into it.

Scroll up to the previous message of mine for a link to where there is a simple answer to what you’re trying to do.

As I mentioned above, it is certainly possible to use Document Template to change formatting, however that technique is best employed for exceptions to the defaults—such as the scenario I describe in that post. It doesn’t sound like that is anything close to what you actually want, but I figured it worth mention of a case where it does make sense to use this feature to set exceptional default formatting.

That is so kind of you, Amber. Thank you.

I can’t actually see how to set line spacing in Options / Editing / Formatting. However, I have created a style for that, and that does very nicely. I don’t even need to select the text for the style to be applied as I need.

That’s true, for paragraph styles. Do be wary however of how styles are a very strong formatting declaration in Scrivener. They are a way of telling the compiler you want text to look a certain way, regardless of what the compiler will be doing by default. This can result in mass confusion when one selects “Manuscript (Times)” or whatever, and only 85% of their paragraphs convert to TNR, the rest having been instructed to use Cochin or Gill Sans or whatever you like to use while writing and managed to save into the style.

As to the original question, line spacing should be showing up in the Editing: Formatting tab, but I suppose if the window is too narrow it might slip off. Bear in mind if you already have a paragraph looking the way you want it to, back in the main window, you can select it first and then click that Use Formatting in Current Editor button to the top right.

Thanks for the warning re styles. Fortunately, for this particular document, there are only three styles (headings, text, lyrics). I appreciate that learning how to compile is going to be a whole new level of pain… :slight_smile:

Just make a mental note that the “Default” setting at the very top of the left sidebar in the compiler is your “easy mode” switch. That does very little beyond stitching things up into one file. For something highly stylised like verse, it may be the best option anyway.

In my Template Sheets folder, I have the Text template formatted the way I want it to with the default Text style chosen. It’s weird that I have to put a bit of text in an empty document to get a style to stick but I’ve done that.

But whenever I create a “new text document” from the right-click menu or from the toolbar drop-down, it creates an empty document without the Text style. It starts with “No Style” no matter what I do. Moreover, even the bit of text I put in the template sheet to get the style to stick is not there.

Yes, it will do it correctly if I drill down and choose Add > New from Template > Text Template but that is rather unwieldy for something I do so frequently.

Isn’t the New Text command the same as New from Text Template? If not, how can I make it so? I’ve set my defaults wherever I can find them but no matter what I do, new text documents are blank without a style. I have to select a style before I even type and that seems ridiculous.

What am I missing?

Hi.

To add a new document from a template, it is either this image from the toolbar (click the drop down arrow / pick your template), the right click menu in the binder, or the main menu :
image

There is a shortcut to add a new document based on the template that is at the top of the list (the one template that would be the topmost in your templates folder).
In the options you may switch this shortcut and the one to add a new document for one another (that’s what I did), or get used to using the other shortcut (Ctrl-Shift-N — or the mac equivalent, in your case) whenever you want to add a new doc based on your template.
image

In short, move that new doc template of yours at the top of your template(s) folder, and use the right shortcut.

. . . . . . . .

By the way :

Your template(s) are/is right underneath.

image

If your template doesn’t appear there when you right click a binder element, it means that your template folder isn’t properly set.
Let us know if that’s the case. We’ll walk you through it.

. . . . . . . .

I have a string of xxxxxxxxx as the first paragraph of my document template. I just double click it and start typing.

(As a side note, though, it is not recommended to style the whole of your body text. I have a good reason to want my template to start with a styled paragraph. Otherwise I’d just use and properly set the default formatting for new documents…)

That hints at the wrong way of doing things… But it is not a catastrophe. Only that you are setting yourself up for some unnecessary trouble later at compile.

The default formatting for new documents is set in the options / editing / formatting.
If you style your whole body text, and always with the same style throughout a project, better to do things this way.
Styles are intended to be used for whatever chunks of text deviate from this default formatting. Not as the base.

3 Likes

To emphasize a point Vincent made, you should establish a default paragraph format, not a default paragraph style.

Then even the plain old New Document command would probably serve your needs without the need of a template at all.

2 Likes

10 posts were split to a new topic: Setting and using templates as defaults for new text

In this post above, I speak a bit on how templates can be used to establish formatting of some sort, though as I stress there, better as an exception to a global default. There is a link to another thread as well that goes into more detail on that.

There are ways to make templates more efficient than always having to pick them, but they will always be less efficient than actually setting the default formatting, if that makes sense, since neither they nor styles were meant for that purpose.