Setting and using templates as defaults for new text

I appreciate both of the responses! I see that the default paragraph format does fix most of this issue for me without the style but I’m still confused with a basic question:

Is the default New Text command different than the New Text Document from Template? I would assume a New Text is from the template but it doesn’t work that way for me. I have a Text Document template that I thought was a default but it only gets chosen if I scroll down to the sub-menu and choose it. Having the command “New Text Document” implies it would be from the Text Document Template but apparently not…

It is not.
A new text document (Project/New Text, in the menu) is a total blank, beside having its “no style” formatting as set in the options at the time it got added to the project.

You can set a template document as the default for new documents in a specified folder.

But unless you do, the default “New Text” will always use the project-wide (or Scrivener-wide) defaults.

1 Like

Is this something that can also be done under Windows ?

[EDIT] Nevermind, found it Document / Default template for subdocuments

That’s great, I didn’t notice this before.


I don’t know how I managed to miss this, but it is truly a little gift.
I’ve set back my shortcuts to normal
(Ctrl-N for a new text doc / Ctrl-Shft-N for new from template),
and now, rearranging my template folder and assigning the proper template for new subdocuments to the different folders of my project template, that gives me not only the “type” of document I want depending on where I am in the binder, but it allows me to set an alternative, to be used in my main draft folder, rather using Ctrl-Shift-N.

For example, I have a template for text documents, and another one for general notes about my ongoing novel. Notes that wouldn’t sit right in the notes panel of a text document (notes that are too generic — pertaining to the big picture — to be associated to a specific text doc ; (plus, I want to see them clearly present in the binder)).
Ctrl-N gives me a new text document from my text doc template when in my draft folder.
Ctrl-Shift-N gives me a new notes document. :+1:

1 Like

Thanks. I was having trouble with this feature because the option was greyed out. It turned out that the “folder” I was trying assign a default sub-document type to was actually a file so I converted back to a folder and then assigned the default document template for that folder.

Still doesn’t work. I’ve tried it on three different folders. Every time I create a new document using the sub-menu, I get a blank document – whether it’s the Characters or Settings or manuscript folders. As a workaround, I’m just going to keep a copy of the template at the top of the folder and duplicate it. That’s easier than routing around for the correct type in the sub-menu.

That would mark your intention…
I think it works only with the shortcut.

I appreciate the help but what this all assumes is that I want to compile everything. Three quarters of what I am writing is not ever going to be compiled. It’s notes and discovery writing. Particularly for notes, it is much easier to have a document formatted for the way that I do notes. As soon as I have an idea, I open a new document and let 'er rip.

It is also confusing that a New Text document and New from Text Template are two separate things. No matter what I assign to a folder as a default sub-document template (Character, Setting, etc), I get a blank Text document.

Use Ctrl-N
Use the shortcut.
Not the menu / sub-menu.

If you use the menu and pick “New Text” and not your template, you actually tell Scrivener that a blank is what you want.

1 Like

Yes, exactly. Scrivener is doing exactly what you told it to, and you told it to override the default.

Note that clicking the ‘+’ icon in the toolbar – not the dropdown menu next to the icon – will create a new document using the defined default template as well.