Define Keyboard Shortcuts

A shortcut I often need in scriptwriting is “Convert to Uppercase”. In my System Preferences there is a Keyboard Shortcut for All Applications: “tOGGLE cASE” = Shift-Command-U. It works in Scrivener, except it also converts the font from Courier (Prime Regular 12pt) to Helvetica (Regular 12 pt)

Font changes in a script are a no-no. Any suggestions about how to preserve the script font using this or another shortcut?

Many thanks


How are you accomplishing this case toggles? I would have assumed you were using some formatting presets in Scrivener, but that wouldn’t apply to all applications.

I suppose you know that there is the possibility to change a marked word with the command Format>Convert>To Uppercase.
In System Settings>Keyboard>Shortcuts (I hope I use the right terminology, my system language is Swedish) I’ve given this a keyboard shortcut (Shift-Cmd-V).
I appreciate the ambition to keep the screenplay in Courier Prime ONLY. For this reason I’ve also switched the shortcuts for Paste, so that the simpler shortcut, Cmd-V, is reserved for Paste And Match Style.

I’m using System Preferences/Keyboard/Shortcuts/App Shortcuts/All Applications. I am using the shortcut Shift-Cmd-U because this is the standard keyboard shortcut in Final Draft, which maintains Courier Final Draft.
For some reason, Scrivener changes the font. I’m sure there’s a setting somewhere to fix this, but I can’t find it.

I don’t know why it’s happening, but I can suggest something for you to try.

Your shortcut is in ‘All Applications’. Could you try deleting it, and recreating it for ‘Final Draft’ only. Then create another shortcut for Scrivener, using the same shortcut, but making sure that the menu item is ‘To Uppercase’. (It’s in Format > Convert.)

That way, shift-cmd-U should invoke the appropriate command in both programs. BTW, the ‘To Uppercase’ command in Scrivener does not invoke a font change for me.

One final thought – your command looks like it actually toggles each individual letter, so dAVID becomes David. Where does that command come from originally? It’s not a standard Mac command as far as I know. Perhaps the original program is making assumptions about fonts which don’t apply universally?

I’ve just worked out the solution, and it was my misunderstanding about how to create keyboard shortcuts. In the System Prefs/Keyboard/Keyboard Shortcuts/ Applications/Scrivener I had labelled the shortcut Shift-Cmd-U “Format Convert To Uppercase”. Now I have changed it to simply “To Uppercase” and it maintains the font.
Thanks for your input.

Glad it’s working now.