Difference in Results Between CTRL+V and 'Paste' Command from 'Edit' Menu

I just copied the Bookmarks, and titles of those Bookmarks, from a folder in Chrome, and pasted them into a container I had created in the ‘Manuscript’ in the Binder.

The first time I pasted the Bookmarks into the folder, I (unusually, for me) went to the ‘Edit’ menu, and chose ‘Paste’. This resulted in just pasting the Bookmarks as text - i.e., the hyperlinks were not preserved.

However, the second time I tried pasting, I used (as I would usually do) the CTRL+V keystroke combination, and I got exactly what I wanted - the titles of the links, with the links correctly formatted as hyperlinks, underneath each title.

My question is why does clicking on the ‘Paste’ command give a different result from using the CTRL+V keystroke combination?

There should not in theory even be a possibility for difference between these two invocations of the same exact command.

Could you provide a precise sequence of steps to demonstrate the difference? All I have to go on here is copying “the titles of bookmarks” from Chrome (which I don’t even understand) and pasting them “into a folder”, which could mean half a dozen different things off of the top of my head.

When writing a bug report, it is good to pretend that the person following it knows next to nothing about what a computer is, because it’s that level of detail that is often required for a bug to be understood or reproduced.

I, too, had assumed that there should not (and would not) be a difference between pasting using the ‘Edit’ menu, and using the CTRL+V keystroke combination - hence my question.

Apologies for my lack of clarity.

In response to your request, here is as clear an explanation as I can give of the context, and the process I went through within that context, to paste the Bookmarks into my Scrivener project.

Chrome has “Bookmarks”, which are hyperlinks to webpages (and also the plain text titles of those webpages: both the hyperlinks and titles are combined in the Bookmark itself, and appear as one text description/title in most instances).

Here is the precise sequence of steps I used to copy those Bookmarks, before pasting them into Scrivener.

  1. Open the folder in Chrome which contains the Bookmarks to be copied (there are various ways to open this folder, but the end result is the same - you are in the folder, and can copy or delete or cut-and-paste, or manipulate the contents in some other way)

  2. Press CTRL+A to Select All (the contents of the Bookmarks folder), Right Click (and select Copy)

  3. Maximize Scrivener (or I might have had the Scrivener window maximized, but behind my Google Chrome window - either way, I went to the already open Scrivener project into which I wanted to paste the Bookmarks from Chrome)

  4. Select the folder (in the Scrivener Manuscript) I had created to which I wanted to paste the Bookmarks

  5. Select Edit - Paste OR (the second time I tried it), use the CTRL+A keystroke combination to paste the Bookmarks into the selected Scrivener folder

Hope this is clear(er).

I have seen a similar result, and sometimes even cmd-v not pasting in macOS from time to time. As far as I could tell, it APPEARED to be a function of the originating (cmd-c) app as the cmd-v would function normally pasting content copied from a different app.

Situations like this are where dmb’s preference for screensharing can be particularly useful.

1 Like

Thanks, I’m getting closer I think. I am using the open source Chromium for this test instead of Chrome, as that should be mechanically identical for testing something like this.

So to get to where I believe I can copy bookmarks bulk, I visit the chrome://bookmarks URL (one can also use the menu button to navigate to this same place). I just added a bookmark to test with:


2. Press CTRL+A to Select All (the contents of the Bookmarks folder), Right Click (and select Copy)

I do this, and at this point I use a clipboard examination utility to see all of the different data types that the software is registering with the system. For example, if we copy some formatted text from LibreOffice, we would expect to see text/rtf, text/html, text/plain;charset=utf-16, text/plain;charset=utf-8 and so on—a lot of different formats are created so that you can paste text into all kinds of software, from other word processors, to WordPress in a website or even Notepad and get a sensible result.

With Chromium, I get:

  • text/plain
  • text/plain;charset=utf-8

Upon examining the contents of these two variants I get a simple flat list of URLs, no titles at all. I could further confirm this result by pasting into LibreOffice and getting nothing but a flat plain-text list of URLs. So I’m not 100% positive if I’m doing the same thing at this point, since you specifically mentioned copying the titles of the bookmarks in the first post.

So we’re already in a somewhat confusing scenario in that I am not sure how you are getting anything more than a flat list URLs no matter where or how you paste after that point.

5. Select Edit - Paste OR (the second time I tried it), use the CTRL+A keystroke combination to paste the Bookmarks into the selected Scrivener folder

At this point I get a system beep, because I am trying to paste three lines of text into the binder sidebar. Presumably there is something else I am supposed to be doing in between step 4 and 5, that would provide me with a valid target for pasting text.

Pressing Ctrl+A for me would select all of the items in the binder at once, it wouldn’t paste, for sure. I’m sure you mean Ctrl+V though.

Hi AmberV,
I am going to suggest (in the same spirit of your post to me earlier in this thread about describing my exact methodology to avoid confusion) that instead of you using “Chromium for this test instead of Chrome, as that should be mechanically identical for testing something like this”, you actually use Chrome (on a PC), in order to try to emulate the problem I have had.

It seems to me that we are trying to eliminate the kind of assumptions about what “should” work.

If we are talking about potential variations, you are introducing further variations by adopting your methodology.

I should also report that I tried the same methodology in a Different Project (trying to eliminate the variables of whether my Original Project was in some way causing/contributing to this problem), and the CTRL-V and ‘Paste’ command from the ‘Edit’ menu functioned identically (i.e., they pasted the URLs and titles of the URLs correctly).

I returned to my Original Project and, sure enough, the problem persists.

My Original Project is now around 140 MBs, and I have noticed that when projects get to that kind of size they seem to suffer more from ‘buggy’ / inconsistent behaviour.

1 Like

Thanks for your reply, RuffPub.

With Chrome and the Bookmark Manager and pasting into Scrivener (ctrl-V), I get titles and links, but no visible URLs (1st attachment). With paste and match style I get URLs only (2nd attachment).

Gotta say, if I may, that makes sense to me, and I’ve often thought to say similar, all in the spirit of “eating your own dog food.”

Woof woof! Scrivener yay! :heart: :smiley_cat:

1 Like

Thanks for the support, Mad_Girl_Disease. :slight_smile:

Chrome and Chromium are essentially the same browser, the only differences being branding, the addition of a bunch of Google data tracking stuff and some proprietary add-ons like Flash and some media codecs that aren’t freely available.

Interesting! That could throw a wrinkle into things.

I’ve done some further testing with additional conditions, and have run into some odd inconsistencies. For example, if I select one bookmark and copy it, then it pastes as a titled bookmark link rather than the raw URL as text. Whenever I test with multiple bookmarks, I get a raw list no matter what. That’s across three different platforms, and using multiple different targets to paste into (TextEdit, LibreOffice, Scrivener). The targets don’t seem to make any difference in this case, I get the same result everywhere, using three different methods for pasting (shortcut, menu, right-click contextual menu).

This post seems to confirm what I am seeing, though alas nobody has responded. I wonder if this is something that has changed in recent builds?

It wouldn’t quite explain what you are seeing though, with the same clipboard acting differently in different Scrivener projects, but at least explains the confusing results I’m getting on my end. I suspect that in order to see the precise issue you are seeing, I would need an environment closer to what you have in the project that reproduces it.

Let’s see if this works:

  1. With your 140mb project that reproduces the issue, use File ▸ Save As... and create a clearly named copy like “Clipboard Test”.
  2. You should now be in the new copy, which you should confirm from the title bar in the window. Proceed to strip out everything in the binder save for one document you don’t mind sharing, and empty the trash.
  3. Open File ▸ Options..., and use the “Manage” button in the lower left corner to “Save options to file…”, and save that alongside the test project.
  4. Close Scrivener, and zip the test project, along with the .prefs file, using File Explorer.
  5. Open the project again, and test the bookmark paste issue. If the problem persists, then in theory if I open that project and try the same thing I should get similar results. If not I can apply your settings preset. Those two conditions together should provide as many contextual similarities as possible.

Send me a DM with the .zip as an attachment. I wouldn’t recommend sharing it publicly as your prefs file may contain personal info from the Author Info section, as well as in the compile settings.

Oops. Just accidentally deleted my reply to you, but copied the text from ‘History’ (is there any way to undelete or restore a deleted message?).

Anyway, thanks very much for your reply, AmberV.

I will try this next week (on Monday, 1st. March), so please expect a DM then.

In the meantime, I am experiencing a more serious issue which I am going to ask about in a separate post.

By the way, you have shown above that Chrome and Chromium are not the same, regardless of how close they may be, and if we are trying to reproduce the same error, then exactly the same apps/programmes and methodologies should be used.

Thanks for your help.

I’ll get back to you later, as I’m about to close things up for the night, but I restored your post for you. I’m not sure if that’s a moderator thing, or something you could have done, but what I did was click on the pencil icon at the top of the post. Deleting is basically an “edit”, and if you have the rights to edit your post, you should be able to revert to a previous edit using that interface.

1 Like

Thanks very much :smile:

Apologies for getting back to you a day later than intended.

I have gone through the steps you suggest above (very clear, thanks for that), but have a question about 4.

Do you mean that I should put the Prefs file in the Test Scriv Project, and then ZIP that and send it to you (as well as opening it and testing the CTRL+V vs ‘Paste’ Command myself), or should I include the Test Project and the Prefs file as separate files in a folder which I should zip?


No worries, I can wait years between responses if need be.

You could import it into the binder, and then just zip the project up, but it works just as well to Ctrl+Click on both the main project folder (.scriv) and the .prefs file together, right-click, and “send” to a compressed zip.

It sounds promising though, the problem reproduces with a drastically simplified data set?