Difficulty importing Word Doc. Comments aren't pasting into Scrivener either.

I’ve been trying to import a 250KB word doc (docx format) with comments from my editor. When I copy and paste into Scrivener, the comments don’t paste with it.

Importing just seems to hang though.

I created a new document to import the file into. I go to File > Import > Files and choose my Word document. A pop up window comes up that says “Import” and a green progress bar shows in full. It says “Importing 1 of 1” with the location and name of my document. And then it sits there forever and doesn’t do anything else.

I’ve tried multiple times, all without success. When I click the ‘x’ in the pop up “Import” window, nothing happens. I actually have to force quit Scrivener to try again.

I’m on a MacBook Pro, running Mojave v. 10.14.5
Scrivener is v. 3.1.2

I seem to remember copying and pasting working in the past, but it’s not working anymore. When I copy even one chapter from the Word file and command + v into Scrivener, nothing at all happens. When I right click and select “paste” nothing happens either. But when I right click and choose “paste and preserve formatting,” it does work, but it doesn’t paste in any of the comments from my editor.

I’m in the middle of editing a 100K+ novel. I really do not want to have to add in all the comments and notes by hand. What else can I try? I hate working in Word.

Please send a note to our support address. If you can, attach a copy of the problem document, and a screenshot of your Scrivener -> Preferences -> Sharing -> Conversion pane. We’ve had a few reports like this, but haven’t been able to duplicate the problem on our end.

literatureandlatte.com/contact-us

Katherine

Will do, thank you.

Since LL can’t replicate my problems, here’s a screencast I took today. For the sake of the length, I didn’t let the ‘import’ window sit forever like I have before. I’ve left it up to an hour or more to see if anything would ever import. It never does.

Here’s the dropbox link to view:

dropbox.com/s/et8hy6uaq4rj4 … M.mov?dl=0

Of note:

  • My preference pane windows for importing and converting are set to defaults. I’ve never changed anything in there. (I sent support screenshots).
  • I have trouble when trying to import any Word file, even one saved with a three word sentence on a single page.
  • I have the same issues when trying to import an .odt file from Open Office or Libre Office.
  • I cannot copy and paste anything from Word, Open Office, or Libre Office by simply cmd+v. If I right click and select “paste” it does nothing. If I right click in Scrivener and select “paste and match style” it works, but I lose all comments and notes.
  • When Scrivener first tries to import, a java thing opens up in my dock. After a while, it turns to a plain terminal icon. I have no idea what that’s about or if it’s significant.
  • Again, when I attempt to close out of the non-functioning import pop up, nothing happens. The only way to get out of it is to quit Scrivener. See screencast. Sometimes I have to ‘force quit.’

I’ll update this thread if anything new is discovered.

As a work-around, you might try first importing your Word doc into Pages and then export your Pages file as an rtf file to then import into Scrivener.

EDIT TWO

The more I read, the more I think that the issue is likely to be related to antivirus software (as mentioned below), but leaving the whole thread here in the hope that some of the other ideas might help if an antivirus program isn’t causing problems.

=========

Hi.

Have you tried:

  1. Using Scrivener’s new converters: https://forum.literatureandlatte.com/t/test-scriveners-new-docx-converters/45402/1

  2. Cold booting the Mac

  3. Deleting Scrivener, rebooting, and then reinstalling Scrivener

Do RTF files import? If yes, can you save the Word file as RTF and then import?

Slàinte mhòr.

EDIT:

Having looked at your screencast again on a larger screen, some more ideas…

  1. Are you running an antivirus program (Intego)? If yes, does the import work with the antivirus program turned off?

  2. Have you tried quitting (CMD OPT ESC) all other applications – including Word – to make sure nothing else is interfering with the process?

  3. Does it work if you log into a different user account?

  4. Does it work if you import into a different Scrivener project?

  5. Does it work if you restart your Mac in safe mode? support.apple.com/en-gb/HT201262

Slàinte mhòr.

I’ll try this. I never use Pages. Does it preserve Word comments?

I disabled Intego, but still couldn’t import. I’m downloading the uninstaller to see if getting rid of it completely helps. I was only trialing the software anyway.


Just tried this after my support ticket suggested I try this one: Untick the ‘Use enhanced converters for Microsoft Word and OpenOffice documents’ setting in the Preferences > Sharing > Conversion window pane.
I can convert with that unticked! Comments intact!

Did try this one before, but it didn’t help.

Did not try this.

Everything ‘hung’ until I unticked the ‘enhanced converters’ box.

Just answering for posterity’s sake. Disabling the Net Barrier didn’t help. They also have a Virus Barrier but I wasn’t running that. However, I am uninstalling it as it was only a trial.

I did try this one several times, but didn’t have any change in importing.

I didn’t understand this one. A different Word account?

I was able to open any other Scrivener project. I just couldn’t convert any other format I tried. Word, OTF, RTF, etc.

Was going to try this one tonight, but I’ll skip it since unticking the ‘enhanced converters’ worked.
Thank you for all the help and suggestions!

Just to clarify what’s going on here…

Scrivener 3.1.2 introduced a new converter for Word documents. Because this converter is still relatively new, it is not the default, but we believe it to be better than the “enhanced” converters, which are third party software that we’ve been using for a while. So, by switching off the enhanced converters, VeryMom enabled the new converter and it seems to have resolved the issue.

See the 3.1.2 release notes for more information: literatureandlatte.com/scri … s?os=macOS

People interested in offering feedback on the new converter can do so here: https://forum.literatureandlatte.com/t/test-scriveners-new-docx-converters/45402/1

Katherine

Welcome.

Glad you have a solution. Seems I was wrong about the antivirus app: I really thought that it alone might explain why pasting wasn’t working, let alone the import issue.

Another user account means creating a second account on your Mac (via System Preferences) and seeing if the same problem occurs in that account. Some errors can be tied to a particular user’s settings, so testing issues through a second user account can be a useful diagnostic tool…but no need to do that now.

Slàinte mhòr.