Distracting comments -- leave the text clean?

Hi,

When inserting comments on words/phrases (to mention an idea/an alternative wording etc), the text becomes yellow and underlined. I find this distracting.

Is there a way for Scrivener to display the text without any change, while adding some icon in the margin to indicate that a comment exists?

Then the comment pops up when clicking the margin icon, but otherwise the text is clean.

Thank you.
Best regards,
Benjamin

Hi.

The highlight color is the color of the comment.
You can change it by right-clicking the comment itself in the inspector.

You can hide comments indicators (highlight + underline) using View/Text Editing/Hide Markup.
What this menu option hides or doesn’t is set in the main options. Appearance/Textual Marks.

The comment itself will remain visible in the inspector.

1 Like

Thanks. If the comment is white, then it’s not highlighted but it’s still the color of links (blue by default). So making links black in Textual Marks > Colors made the comments discreet enough.

Adding the option to display comments only in the margin (as in Final Draft for example) would be a nice feature.

You can have them not underlined too.
Same option panel.
Second checkbox (under Windows).

I’d personally leave the links blue, and do that.
Indeed, no margin indicator, but the comment remains visible. So…

1 Like

Thanks, I just did. Back to default blue for links. View > Hide Markup is enabled, and Preferences > “Hide Markup hides links” is checked (but “Hide Markup hides comment highlights” is not checked, otherwise comments are entirely invisible). Now comments are only indicated by a pale gray box around the commented text, which is discreet.

2 Likes

You don’t have to hide markups and links if in the options (same panel) you uncheck the option to have comments look like links.
Which imho would be optimal.

You wouldn’t have issues with links displaying no visual cue, nor to constantly toggle the menu option to hide\show markup.

1 Like

OK, but I don’t see any option “comments look like links”…

Oh. That’s unfortunate.
Here it is under the Windows version :
image

Perhaps it is simply somewhere else for you. (?)

1 Like

Apparently the Windows version is ahead on this…

:man_shrugging:

One of those tiny and rare little advantages to the Windows version, perhaps perhaps.

1 Like

I have another problem now, displaying page numbers in Screenplay mode… (made a new topic about it).