Divider lines appear in non-scrivenings view

I found a new bug in 2.0.1 with the Scrivener divider lines, similar to something that was happening sporadically for people in 2.0 with the lines covering text. When switching from the crop marks to the divider lines, all the documents in the Scrivening session open when I switch will appear with the divider lines running through the first line of text when viewed as a single document:


To reproduce:

  1. Open a Scrivening session with folder A containing documents A1 and A2
  2. Open Preferences and select to “separate with single line breaks”
  3. Deselect “separate with single line breaks”
  4. View A1 or A2 as a single document

I’m getting this consistently, whether working in split pane or with a single editor, and whether or not I type or work in between switching from the single line break to the divider lines. Even if the project opens with the single line breaks already set, switching to the divider lines causes this problem. The only way I’ve found of restoring the document view is to close and reopen the project.

If multiple documents are selected in the Scrivenings view instead of a folder, the first document doesn’t seem to get this problem, but all the others do.

Also, it only seems to happen if the Scrivening session is open when the preference change is made.

Could you check your Formatting preferences pane? There was a difficult to achieve bug in a prior version that would cause these dividers to end up in the formatting pane, and thus propagate to all new documents.

Sorry to be dense, I still have post-Thanksgiving-cleanup headache. What am I checking for?

Preferences:Formatting:Main Text Style. Do you see the divider line inside this mock editor area where you can configure default styling. If yes, that is what is generating it. Select some non-buggered text and click “Use Current” to fix it.

Might also check Project/Text Preferences... if you’ve messed with that.

Ah, thanks. No, the lines don’t appear in either.