Document titles do not appear in compiled PDF when I select entire folders

When I attempt to compile my entire draft folder—which contains three section subfolders and then chapter documents within each subfolder—I cannot get the document titles to appear in the compiled PDF, despite using what look to me, having read a few posts on this board, like the correct formatting settings. Notably, when I only select a few documents within a subfolder and compile only them, using identical settings, the document titles do appear in the PDF. Can someone help me figure out why the titles won’t appear when I try to compile everything, including the containing folders and subfolders as well as the documents? I do not have any of the documents set to “compile as-is”; as mentioned, the titles do appear if I compile only a few documents within a subfolder.

Thanks for any help you can provide!


Hmm, you’re settings look okay from the screenshot, save for one potential caveat we cannot see. In the third shot, the Formatting pane, if you look closely at the scroll bar it looks like you might have another entry here, and if you do the only possible type of entry you could have is a Level 2+ file row, which is perhaps not set up correctly to print titles.

That would correlate with your description of if working when only selecting a few items. If you do that the easy way with—the “Current Selection” feature—then the result will be a flat list of files, and in that case they would become Level 1 files and match the rule we can see in the screenshot. They are otherwise, being nested beneath folders, level 2 files.

Aha, that was exactly it! Eagle eye on the scrollbar. I checked off the title box there, and it’s now working as desired.

Thank you so much!