Documents empty! A rather serious bug, or …?

Two things are possible: there is a rather serious bug in Scrivener, or there is a rather serious bug in me.

Yesterday I imported some 40 documents into a new Scrivener project, after having converted them from Word and other proprietary formats into RTF. I divided them into various folders, and worked for some time with them. All documents contained the text they should contain, and everything seemed to be fine. Then I closed the project, turned off my Mac and went to sleep.

This morning I open the same project. The documents imported twelve hours earlier are all listed in the binder, as they should be, but when I try to open some of them, I discover they are all empty (Words: 0 Chars: 0) except three, which contain the text they should contain. No, I was not looking at the outliner, I was looking at the documents themselves, with the soft green background I had given them. The soft green background is still there, but the text is gone.

When I check the content of the various folders in Corkboard view, each synopsis shows the first words of each document: which proves that these documents have indeed been imported, and that their text is possibly still there. But it stubbornly refuses to show up in document view.

What on earth could this be? I never experienced this with Scrivener, nor, as far as I can remember, with any other application.

P.S. I can remember that when working with this project yesterday evening, I moved it at a certain moment from one folder in the finder to another one. Could this have anything to do with it?


This is very strange and I have never heard of this happening. Could you please send me your project? It sounds very much as though, for some reason, Scrivener can no longer find your files inside the .scriv package. My guess (hope) is that the files will still be there. I really need this project to have any chance of checking this one.

Maria’s summation about the other stuff is correct.

I do hope that Scrivener or the project was not open when you did this…
EDIT: Although testing suggests that you shouldn’t lose files even if you did do this.

Thanks, sorry you are experiencing problems,

Thanks, Maria, for your quick help! No, I didn’t loose anything. In the first place I still have the originals. After conversion, I never throw them away before being absolutely sure they work (and are complete) in their converted form.
In the second place I make a daily copy of my HD on another, external HD; and my backup application preserves for three months copies of everything I changed on my ‘principal’ HD or removed from it on this external HD.
In the third place I keep rather recent copies of all essential documents both on another desktop and on my laptop.
And in the fourth place I keep rather recent copies of all my essential things in another place, outside my home. So even if my house burns down, I still have copies of my work.
To many all this may seem a bit exaggerated, or even a bit psychopathic. But I’m living with the terror of losing my electronic archive, which contains the fruits of many, many years of reading, writing and collecting.

Anyway, the package contains only five things: the three documents which are still fine, a document called “binder.scrivproj” and a document called “binderstrings.xml”. When I try to open the latter, I get the message “Import Error. The XML document is not in Word format”. The message window contains a yellow triangle with an exclamation mark and Pages’ icon (the inkpot).

Keith, I’ll send you a copy of this project.

Thank you for sending me your project, Timotheus.

This is a very strange one. The weird thing here is that the files that have been lost no longer exist inside the .scriv package - this is why they are coming up blank. However, Scrivener should never cause an error like this - Scrivener is designed to be as safe as possible and therefore does not delete files willy-nilly. There are only three instances in which Scrivener will delete files, and all three go through the same method:

  1. If you choose to Empty Trash. All files in the trash will be deleted from the file package.

  2. If you merge documents. Once the documents have been placed into one, combined document, the extraneous documents will be deleted.

  3. If you delete a saved search. This works the same as emptying the trash, but saved searches get deleted immediately (after a warning message) rather than getting sent to the trash.

In all three cases, exactly the same chunk of code is used. And if files are deleted from disk successfully, this chunk of code also removes them from the binder; if there is any error in removing them from the disk that would prevent them from being removed from the binder, this chunk of code spews an error. So in either case, you would know that there was a problem.

All of which leads me to think that this was caused by some sort of disk error when moving the project. Because .scriv files are actually file packages (in other words, just folders with special icons to make them look like files), they are susceptible to the same problems as normal folders when moving them. For instance, if you tried to move one on to a drive with not enough disk space, it would be possible for some of the contents not to get copied across, which would cause the problem you are seeing. But in this case, Finder should spew an error.

All of which is a long-winded way of saying: I am really stumped by this issue. I am fairly confident that it is not a bug with Scrivener, because Scrivener successfully imported all the files (I can tell that from the binderStrings.xml file and the fact that you could open them in the first place) and has no code that could possibly delete your files without you wanting it to. So: I think this is some sort of disk problem. But I really would appreciate it if you could walk me through everything you did to lead up to this problem, and whether you did have any copying errors at any time or anything else strange.


P.S. The error you got when trying to open up the XML file just means that your system is set up so that Pages is the default application to open XML files. If you ctrl-click on the file and open it with something like TextEdit, you will see all of your text as plain text in there. This file is just used for searches inside Scrivener and with Spotlight.

And now the haze of mystery is beginning to clear up a bit … Five minutes ago I find between the documents in the Trash (the trash of my account in the dock, not Scrivener’s trash) a complete copy of the project, with all documents in their place! The name of the copy is identical to that of the nearly empty copy I sent to Keith.

So I am beginning to suspect that this problem has really something to do with my moving or copying this project from one folder in the finder to another. Probably I moved and / or copied the project from one folder to another, after which at a certain moment I discovered there were two projects with an identical name, and trashed one of them: the copy I found five minutes ago in the Trash.

I probably did something stupid I should never have done: moving or copying the project in a wrong way or at a wrong moment. But such things sometimes happen after a long day of work, shortly before midnight … So it looks like the bug was in me …

Still, I don’t understand how the damaged copy can contain the complete series of the documents in the binder, but not their content. All I can say is that the system at a certain moment probably got out of order and lost trace of the content of certain documents. I’m sorry for this confusion!

I’m glad you found your full project!

This is definitely a weird one, but it sounds more and more like something went wrong with copying the project. I think I should add something to the FAQ and help file emphasising how .scriv files will be susceptible to the same problems as folders.

You didn’t accidentally (or even intentionally) stop the copying process at any point, did you? Perhaps, for instance, you moved the project, then changed your mind and stopped the move, and then trashed the wrong project? A half-copied project would display the problems your project had. It must be something along these lines, I think.

Anyway, I am relieved that this is looking like it is not a Scrivener bug… :slight_smile:


No, I didn’t interrupt the copying process. But in the midnight hour I probably made some kind of wrong move which upset part of the system. Anyway, it doesn’t matter anymore. Thanks, Keith (and Maria), for your understanding and your help!