Docx No Internal Links

I’m publishing on Draft2Digital. The epub worked okay but they warned it can’t use as many features as docx.

The compiled a docx and it doesn’t have any internal links for navigating… they are all just text.

Did you set up your compile format’s section layouts to include RTF bookmarks? That is necessary for internal links to be included in a .docx.

All the best,

Super! We’ll do that.

Okay all Section types have Settings>Include in RTF Bookmarks checked.

Also under Compatibility Ensure Hyperlinks are coloured and highlighted.

Still not working.

Sorry for the late reply - I’m deep in dark mode code at the moment. I’ve double-checked and it’s all working fine for me. One thing to note is that the links don’t look like links in Word because they are bookmarks rather than hyperlinks, although you can go into Word’s Preferences and set it to show bookmarks in the “View” preferences, which marks bookmarks so that you can see where they are.

If the bookmarks aren’t there at all still, please email us at AT and include a zipped up sample project that shows the problem so that we can take a look at what is going on.

Thanks and all the best,

I’m having the same problem, it seems: Compiling to .docx, no hyperlinks
Cross-referenced section numbers are correct, but no hyperlinks are created.
Cross referencing in the form of page numbers just gives a ? (and no hyperlink)

I’m sure this used to work.

I have checked and double checked the settings…

P.S. I’m on a Mac, OS 10.13.6, Scrivener v3.03

I don’t know if this matters, but the project I’m working on was originally a Scrivener 2 project.

As I said to the op, who hasn’t yet replied, we would need to see a sample project, as this is all working fine my end. And also as I said to the op, the links may not be blue or underlined in Word but may still be there, so that is also something to check.

All the best,

There are definitely no links or bookmarks! I first noticed the problem because the page number references (<$p>s) did not resolve.

This was working on 12 May, when I (finally) taught myself how to do automatic section numbering and cross-referencing, i.e. I was paying particular attention to it. (Must admit, I can’t be absolutely sure of the hyperlinking as that wasn’t particularly important to me, but all the cross-references were resolving correctly and, when the problem appeared, I hadn’t made any changes to the compile settings in this respect. Since then I’ve told it to highlight them.)

Have emailed a cut down version, almost everything completely deleted except Chapter 2. Even though I’ve done that, and removed the figures, the compressed file is still over 10Mb. If you can’t receive this let me know and I’ll send it via an intermediary site.


Thanks for the project. The reason you are not seeing bookmarks included is that you have set your “Text” and “Section” types to compile using the “As-Is” layout. As-Is does not include RTF/Word bookmarks for those documents. To fix this, in your Compile format, simply create a new Section Layout that includes the text but doesn’t override it, and then ensure “Include in RTF bookmarks” is ticked in the “Settings” area of Section Layouts.

I can see how this would be confusing, though, so for the next update will make it so that “As-Is” includes RTF bookmarks for each document.

All the best,