Does font size matter when exporting to .mobi?

I have the font size set to 18 in Scrivener for my aging eyes. Before I compile to a .mobi file, do I need to change that for the Kindle? Or am I correct in understanding that Amazon’s software changes it to what they prefer anyway?

You’ll want to use the “E-book” compile preset. This one is optimised for the way you are working. It will produce a font and paragraph format that is good for the Kindle no matter what you throw at it. To activate the preset, use the “Format As” drop-down menu in the compile window, and select “Manage Compile Format Presets”. Put a checkmark beside “E-book” and click Ok. You’ll need to use the Format As menu again to select the preset. By default this will use .epub, but you can just switch that to .mobi to work with Kindle.

Okay, I see, thank you. I have a couple more questions. After changing to .mobi and making my adjustments under All Options, it changes to Custom. Can I save that Custom preset somehow?

Also, how do I get my links to appear as hyperlinks? I have “Convert Scrivener links to HTML links” checked under HTML Settings but that’s not doing it. Is there something else I have to check?

Thanks for your continued help!

You can save your own preset by selecting “Manage Compile Format Presets…” from the bottom of the “Format As” menu in the Compile pane. This opens a panel; click on the “+” button to create a new preset using your current settings.

As for hyperlinks, do the links link to documents that are included in the compile?

All the best,

Oh, thanks, I missed that plus sign.

No, the links are to outside web sites.

That should be working. What are you using the preview the .mobi file with? I tried with Kindle Previewer and got clickable links, both for a URL I typed in raw, and for one that I supplied to a range of text with Edit/Add Link....

Also, check Transformations and make sure “Remove all hyperlinks” is disabled.

I’m using the Kindle app for my iMac to preview. For some reason, a couple of my links automatically became hyperlinks but the others didn’t. I didn’t know about the Edit > Add Link thing, thank you - I did that for all of them and now they’re fine.

Incidentally, I can’t find “Remove all hyperlinks” under Transformations, is that a Mac vs. Windows difference or something else, just out of curiosity? In any case, thank you so much for your help - I am ready for Amazon now! :slight_smile:

Actually, come to think of it, that might be a beta thing. It’ll be in the Mac version 2.1.1 when that comes out soon. At least you don’t have to worry about it being on in 2.1. :slight_smile: