double quotes appearing as black boxes

I just want to share my experience with using Scriviner with you.

I am writing my novel using Scrivener. Every now and then I post a chapter which I have finished on a website.

To do so, I first select “file” - “compile draft” - “highlight only the chapter I’m interested in” - “Export Format = Rich Text (RTF)” - “Export”

Then using Textedit program I open the RTF file and select everything and post it to the website.

My problem is that the chapter on the website looks fine when I view it on my Mac.

But when my friend views it on his PC (windows XP) all the double quote character looks like black boxes.

I track down the problem to the fact that double quote characters takes up 4 bytes instead of 1 byte on the RTF file.

To fix the problem, I have to run the following perl program on the RTF file first before copying and pasting it to the website.

perl -pi.backup -e “s/\\'9[34]/”/g" ChapterThree.rtf

What the above perl script does is to replace

[][’][9][3] with ["]
[][’][9][4] with ["]

Do you have any suggestions for me?

Thank you

Steven Siew

Pasting “special” characters directly into web page content has always been somewhat problematic, and it is generally best to use the HTML entities instead, such as ” instead of “. I don’t think Scrivener’s HTML exporter catches those, though. While it will look less typographically pretty (though the example you posted seems to be doing that anyway) you could try using the straighten quotes option, in the second tab of compile.


Yes, as AmberV says, instead of doing this manually, you can select “Convert typographer’s quotes to straight quotes” in the Text Options pane of Compile Draft.

All the best,

Thank you. I will give “Straighten Typographer’s quote” a try in the compile draft’s text option tab.

Steven Siew