Draft export: MultiMarkDown --> LaTex

Dear Tech Support,

I’m having a problem exporting Scrivener drafts via MultiMarkDown --> LaTex. The problem is that in the Latex files paragraphs are not separated from one another but, instead, are run together as uninterrupted blocks of text.

I’ve tried setting the Scrivener Preferences/General/Merged Ducuments/Merged Documents setting to “Double newline” but it does not work for me.

Any help will be most appreciated.


Are you entering double newlines between paragraphs in your actual text?

If so, then hopefully Fletcher (the MMD creator) is around to help you. Whilst MMD is built into Scrivener (I set it up with help and testing from Fletcher), I’m not an MMD user myself, so defer to Fletcher, Amber and others on MMD issues…



The “merged documents” setting only adds a double newline between documents, not between paragraphs.

In order for LaTeX to recognize a paragraph break, you have to have a double newline between each paragraph. You’ll have to do this while typing; it isn’t something that Scrivener can do for you.

Dear Keith and janra,

Many thanks for responding to me. Scrivener is a wonderful writer’s tool and helped me to complete a book, but I’m still exploring its many capabilities.

I hoped to be able to export my Scrivener manuscript file via MultiMarkDown --> LaTeX without having to go back to my original file and manually insert double newlines between each paragraph–which will take much time and effort–and wondered if someone had figured out how to have Scrivener do so automatically.

Dewey McLean

Hi Dewey, as the creator of Scrivener I am afraid to say that there is no way of doing this automatically. Of course, you could use Find & Replace to replace newlines with double newlines (you will need to hold the Opt key down to enter a newline into the Find panel), but this will also add an extra newline to any double newlines.

But, if you are exporting via MMD the “triple” newlines will have no negative consequences.

You may find an unintentional paragraph break, however, if you had a “hidden” newline in the middle of a paragraph. But I suspect you would have seen this in your document if you had Scrivener set to display extra spacing around paragraphs, as it sounds you do.


Dear Keith and Fletcher,

You made my day. Using Find & Replace to replace newlines with double newlines in my manuscript (holding down the Opt key) causes LaTeX to recognize paragraph breaks. The extra newline added to existing double newlines is but a minor inconvenience.

With much appreciation for your help, I am

Cordially yours,

You can probably fix the triples, if they bother you, by searching for triple-newlines and converting back to double-newlines, using the same technique.

I like to turn off paragraph spacing in my Scrivener preferences. Since I use MMD exclusively, I’d rather be able to see exactly what is going to be in the exported document. Same goes for indenting.

Triple or quadruple?