Drag and drop does not work in 3.0.1

BAsic Drag and drop with text does not work

Select text
click in selection to drag it
to notes or anywhere in the text
is not possible,
because it looses the selection when you start movving the selected text…
PLS fix this asap. T
his is an hundred year old Mac feature, anbody is trained and working with it …

I have tried it 10 Times after updating to 3.0.1

It works for me in 3.0.1, OSX 10.3.2.

Did you try restarting your computer? High Sierra tends to forget its basic functions from time to time, I’ve found.

It does work - you need to hold the left mouse button down for a couple of seconds - this behaviour is also observable in Pages.


Thanks Ray, i know this. I hold the btn many times for a couple of seconds, but it did not work…

Thanks AHAB, i have restarted it and it works now: Strange…


Not Strange: this bug arrived with High Sierra in Scrivener v2, and has persisted in Scrivener 3. A restart fixes it for me; sometime putting the machine to sleep and waking it back up. High Sierra is the buggiest Apple release I can remember in OS X.

This is indeed a very annoying problem. For some reason I find the situation worse in Scrivener (3.0.1) than in many other applications, but then I use it more in Scrivener so perhaps notice it more there. Nice to at least understand it is a MacOS bug rather than a Scrivener one, though if the latter we would have had more chance of getting it fixed :confused:

I experienced this as well on a MacBook Pro, every time I tried to click and drag to select text I would get the dictionary popup instead.

I managed to resolve this by going to System Preferences>Trackpad>Point and Click then disabled the “Force Click and Haptic Feedback” option. I was thereafter able to drag select as normal.