Drag and Drop Failure

Today, dragging and dropping text failed. That is, select some text then click and hold on it. The cursor did not change to an arrow, and I couldn’t drag the text.

I closed Scrivener and started it again, and then it worked fine. Note that I tend to leave Scrivener running.

Known problem?

On the Mac, it’s necessary to first select text, then click and drag. If you select text, then attempt to drag without releasing the mouse and re-clicking, it won’t work.

If the necessary delay between the two operations seems unduly long, check your mouse sensitivity options in System Preferences.


Thanks, but that’s not the issue.

  1. I saw it failing in Scriv.
  2. I experimented, and no matter how careful I was, the selected text wouldn’t drag.
  3. I did the same thing TextEdit. Dragging and dropping worked fine.
  4. I quit and restarted Scrivener, and it immediately worked fine.

For that reason, and for a bunch of other that have been discussed to death, don’t leave Scrivener running?

Reasonable advice, but often I haven’t decided to finish writing for the day. Get up for lunch, for example, life happens, and I don’t get back to it until the next day.

This is what the autoclose command is for. Scrivener -> Preferences -> General -> Automatic Quit.

This sounds like the sort of thing we sometimes see if the project display settings have become corrupted. If it starts to happen on a regular basis, please open a support ticket so that we can do more in depth troubleshooting.


I think I know what’s going on. In Scrivener, after I’ve been using it for a while, when I click on selected text I must wait two seconds before I can drag it. In every other app (Textedit, word, chrome, for example) I’ve tried on my Mac, I do not have to wait at all.

This video illustrates this:


After I restart Scrivener, the delay is almost, but not quite, instantaneous. I will make note of how quickly that required delay starts increasing.

Does it depend on your usage pattern? Big Scrivenings sessions vs. individual documents? Lots of new research material?


I don’t know yet. I’ll keep an eye on it.