Dragging Scapple <-> Scrivener not consistent

I think this is a bug. Or a really subtle feature set that makes no sense. One of the two :slight_smile:

  • Dradging from scrivener doesn’t work from the outliner or binder, but I can drag items from the cork board into scapple. (would be nice if the display text was the synopsis notes rather than the body of the document, but that’s just a feature nicety)
  • Dragging from scapple into scrivener doesn’t work in the cork board or outliner, but does to the binder.

Maybe I’m not the brightest user (it’s been said), but shouldn’t this behaviour be more consistent? Of the lot, the cork board or outliner would be ideal, but at least if it was consistent (items only worked moving into the binder, for example) it would make more sense :slight_smile:

Scapple 1.0 (3996)
Scrivener 2.4.1 (22817)
OS X 10.8.3
Saturday, mild weather, no clouds. :slight_smile:

Hi Mike,

Dragging from Scapple into Scrivener works in the binder and in the freeform corkboard. In general, the binder is the only place that accepts imports from other programs, but with Scapple I made the exception so that you could drag into the freeform corkboard, as that is the most natural place for such drags. (It has to be in freeform mode, though.)

When dragging from Scrivener, you can only drag from the freeform corkboard, as that is the only place that is similar in organisation to Scapple. You should be getting the title and synopsis of the card dragged into Scapple, not the body of the document, though.

There’s definitely a good case for allowing drags from Scrivener’s binder to Scapple, so I’ll add that to the next updates.

All the best,


Bah! I never even tried the freeform cork board (usually not my thing) - you’re (of course) right, dragging from the freeform corkboard works as advertised, title and synopsis only. It is only in the static/stagnant corkboard that dragging is pasting the contents of the document instead.

I realize this wanting to drag back and forth is all bonus material at this point - on the upside, there’s a hidden feature that lets you drag from the static cork board! :slight_smile:

Woah, I just spent all morning wondering why I couldn’t get Scrivener’s binder to drag to Scapple (even after implementing the code). Eventually, after running lots of tests and narrowing it down to something specific with Apple’s NSOutlineView/NSTableView class that is used by the binder, I came across this:

At least I found the fix, but wow, this bug has been around in OS X for eleven years!

You’re welcome. This is how I contribute - helping you discover bugs that have lain dormant for over a decade so you too can be frustrated at a user and the underlying OS.


(Actually, I feel bad, because while it seemed bug worthy, it wasn’t something I would have suggested required you earning frustration and annoyance from)